IOS Mobile Recording: Root Element Missing Error

Ranorex Spy, Recorder, and Studio.
Rahul Sharma
Posts: 2
Joined: Thu Nov 13, 2014 6:07 am

IOS Mobile Recording: Root Element Missing Error

Post by Rahul Sharma » Thu Nov 13, 2014 6:20 am

If i am trying to Start Mobile Recording on IOS Device it was Showing : Root Element Missing Error.
Ranorex Studio Version is: 5.2.0.20272
IOS Version: 8
Mobile Device: iPod,iPhone
Attachments
Error.JPG
Error.JPG (116.18 KiB) Viewed 650 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: IOS Mobile Recording: Root Element Missing Error

Post by Support Team » Fri Nov 14, 2014 2:15 pm

Hi Rahul,

Unfortunately we are not aware of such an issue. May I ask you to provide additional information about your test environment?
Therefore, please answer the following questions:
  • Does this problem also occur with other applications?
  • Is the application instrumented correctly?
  • How is your device connected with Ranorex (WiFi/USB)?
  • Please also describe the steps you’ve done in more detail.
This will help us to analyze the issue in more detail.
Thank you in advance.

Regards,
Markus (S)
.
Image

Rahul Sharma
Posts: 2
Joined: Thu Nov 13, 2014 6:07 am

Re: IOS Mobile Recording: Root Element Missing Error

Post by Rahul Sharma » Mon Nov 17, 2014 6:52 am

Hi

To make issue more clear to your understanding i am sending you details asked by you:

1. I am using 32 bit Windows XP service pack 3 .
2. I have followed all the steps mentioned in help document to ensure proper instrumentation of IPA.
3.Same problem is occurring with sample IPA also.
4. I connected device using USB.
5. Following steps i have followed during application preparation for testing.

* I used Xcode 5.1 for instrumentation.
* library file used for instrumentation "libRxAutomationUni_170.a".
* Application is prepared and deployed on device using Xcode.
* Opened device on XP machine using USB Connection.
* Created new project solution in Ranorex Studio.
* Click on start recording after selecting mobile recording in recorder setting page and it throws the error "Root Element is Missing".

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: IOS Mobile Recording: Root Element Missing Error

Post by Support Team » Wed Nov 19, 2014 11:10 am

Hi Rahul,

We are currently analyzing this problem on our side and we will get back to you by email.

regards,
Markus (S)
.
Image