IOS : Ranorex Duplicate cells on table and cannot set text

Bug reports.
User avatar
wrodriguez
Posts: 9
Joined: Fri Dec 19, 2014 5:03 pm

IOS : Ranorex Duplicate cells on table and cannot set text

Post by wrodriguez » Tue Aug 18, 2015 3:48 pm

in our app we have a uitableview for questions for user profile,
it has cells for the "select a question value" and cells for the answer field,

now when i click on select a question it displays another table with list of questions to pick from, once that question is chosen it comes back to uitableview with the answer fields.

when it loads that table again, ranorex gets confused and says there are two cells with index of 0.

all other cells are correctly working. So when i set value for answer field it works fine on every other field except the duplicated cell. Im currently blocked from moving forward with user testing. anyone have any idea what could help?

I asked dev how they build the tables and they use dequeing with uitableview. I'm including the snapshot of ranorex to show how it displays


any help would be appreciated.
Attachments
duplicated cells.rxsnp
(83.42 KiB) Downloaded 51 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: IOS : Ranorex Duplicate cells on table and cannot set text

Post by Support Team » Thu Aug 20, 2015 4:39 pm

Looking at the snapshot we found that some of the cells were duplicated, but invisible. To account for this issue we can simply add @visible=’True’ to the RXpath to make sure that only the visible containers are matched.
Screenshot.png
Screenshot.png (55.12 KiB) Viewed 632 times
Thanks,
Hansel
.
Image