iOS Testing, getting Device Timed out in TouchStart

Ask general questions here.
donphanlivemagic
Posts: 1
Joined: Mon Apr 15, 2013 6:55 pm

iOS Testing, getting Device Timed out in TouchStart

Post by donphanlivemagic » Tue Apr 16, 2013 9:57 pm

Hello.

My iOS script is running fine until I try to slide the scrubber on my App.
I know for sure that my instrumented app is running on the device (otherwise, none of the scripts work ).
Any idea?

Thanks,
--DP

NOTE: Here is the error I got

Device communication timed out. Either no instrumented application is running on the device or the device was not able to process the request within the specified timeout of '00:00:05'. Check that an instrumented application is running on the device or try to increase the timeout.
Show/Hide Stacktrace
at Ranorex.Plugin.Mobile.XmlRpc.XmlRpcEndpoint.WaitForReply(TimeSpan responseTimeout, Int32 callId) at Ranorex.Plugin.Mobile.XmlRpc.XmlRpcEndpoint.Call(MethodCall mc, TimeSpan responseTimeout) at Ranorex.Plugin.Mobile.Network.ApplicationChannel.TouchStart(String loc, Int32 elementIdentifier) at Ranorex.Plugin.Mobile.Network.ApplicationChannel.Touch(TouchEvent evt, Int32 elementIdentifier) at Ranorex.Plugin.Mobile.Elements.GenericUiElement.Touch(TouchEvent evt) at Ranorex.Touch.TouchStart(Element element, Int32 pointer, Location location) at Ranorex.Adapter.TouchStart(Location location) at ReplayApp_demo.ReplayApp_VideoSearch.Ranorex.Core.Testing.ITestModule.Run() in c:\QA\ReplayApp_demo\ReplayApp_demo\ReplayApp_VideoSearch.cs:line 210 at Ranorex.Core.Testing.TestSuiteModule.RunInternal(DataContext parentDataContext

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: iOS Testing, getting Device Timed out in TouchStart

Post by Support Team » Thu Apr 18, 2013 4:13 pm

Hello,

Could you please try to increase the Connect Timeout as shown in settings as shown below?
MobileConnectionTimeout.JPG
MobileConnectionTimeout.JPG (62 KiB) Viewed 1533 times
Regards,
Markus (T)
.
Image

wnordstrom
Posts: 1
Joined: Tue Jun 11, 2013 4:11 pm

Re: iOS Testing, getting Device Timed out in TouchStart

Post by wnordstrom » Tue Jun 11, 2013 4:20 pm

Same issue.
ranorex studio version 4.0.4.23593


When I touchstart center I get the following:

Device communication timed out. Either no instrumented application is running on the device or the device was not able to process the request within the specified timeout of '00:00:10'. Check that an instrumented application is running on the device or try to increase the timeout.

By default it timesout in 5 seconds, but changed the rpc timeout to 10s.

if I change it to a touch center event, then the step succeeds. Need to drag. Any ideas?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: iOS Testing, getting Device Timed out in TouchStart

Post by Support Team » Wed Jun 12, 2013 4:18 pm

Hello,

Could you please give me more information about the issue?
Are you sure that there is no problem with the network connection?
Could you send a Ranorex Snapshot file in order to provide more information about the element in question?
Which iOS version are you using?

Thank you!
Regards,
Bernhard
.
Image

User avatar
sincoew
Posts: 48
Joined: Mon Nov 19, 2012 7:42 am

Re: iOS Testing, getting Device Timed out in TouchStart

Post by sincoew » Fri Sep 06, 2013 9:07 am

same issue

Ranorex version 4.1
Via Usb to connect iPhone 4.

Best Regards,
sincoew

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: iOS Testing, getting Device Timed out in TouchStart

Post by Support Team » Mon Sep 09, 2013 3:07 pm

Hello sincoew,

Unfortunately it is hard to reproduce the issue without some detailed information.
Would it be possible to share a video or something similar in order to show us your issue?
Thank you!

Regards,
Bernhard
.
Image