Issue: LineageGlueRule 'qt_child_components'

Ranorex Spy, Recorder, and Studio.
damien
Posts: 17
Joined: Wed Jun 24, 2020 8:17 am

Issue: LineageGlueRule 'qt_child_components'

Post by damien » Fri Apr 16, 2021 3:30 pm

My colleague has an issue while running test suite to test our application.
The tests are built correctly, the tests started but after some actions, the following message is returned:
LineageGlueRule 'qt_child_components' caused HwndInvokerException on Execute. Exception of type 'Ranorex.Core.HwndInvokerException' was thrown. Window Handle: 1640062.Orig.Message:System.AccessViolationException:
--> This happens by searching the button "Play" of our application.

We tried to change some settings like described here:
lineageglue-qt_child_components-rule-ca ... 10643.html

but we still have the same issue.
My colleague is using Ranorex 9.5.0

Thanks in advance for your help and support.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6544
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Issue: LineageGlueRule 'qt_child_components'

Post by odklizec » Tue Apr 20, 2021 8:48 am

Hi,

I'm afraid, this kind of issue is most probably not solvable via this forum. It looks as technical type of problem, which must be checked by Ranorex developers and they will, most probably, need access to your app. Eventually, they will need a working demo app, featuring the problematic button. So if your company is not ready to share the app with Ranorex support, ask your developers to prepare a small sample app, with problematic button. Then create a support ticket here:
https://www.ranorex.com/support-query/
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

damien
Posts: 17
Joined: Wed Jun 24, 2020 8:17 am

Re: Issue: LineageGlueRule 'qt_child_components'

Post by damien » Tue Apr 20, 2021 12:27 pm

Allright,
thanks for your answer, I will then create a ticket as you propose.

damien
Posts: 17
Joined: Wed Jun 24, 2020 8:17 am

Re: Issue: LineageGlueRule 'qt_child_components'

Post by damien » Fri Apr 30, 2021 11:54 am

For those who might have the same problem, my issue here was that an UI element has been changed and Ranorex couldn't find the path anymore.
You can easily check with "Spy" if the RanorexxPath is broken or not : some (x) are displayed next to the last path of your UI element