Issue validating field in windows calc app

Ranorex Spy, Recorder, and Studio.
SeanP
Posts: 60
Joined: Wed Sep 01, 2010 11:48 pm
Location: Irvine California

Issue validating field in windows calc app

Post by SeanP » Fri Oct 19, 2012 8:56 pm

I just returned from the ranorex training in San Fran and I was walking through the process with my group and we found that with Windows 7 when we recoreded a 1 + 1 then hit equal then did a validation in the text field for 2, we kept getting null as the value it was comparing when in reality it was a 2. Any clue what is going on?

User avatar
artur_gadomski
Posts: 207
Joined: Mon Jul 19, 2010 6:55 am
Location: Copenhagen, Denmark
Contact:

Re: Issue validating field in windows calc app

Post by artur_gadomski » Mon Oct 22, 2012 6:39 am

Are you using this text box:
/form[@title='Calculator']/element/container[@caption='' and @class='#32770']/text[@controlid='150']
?
Calculator has a bunch of other text boxes that do not contain answer.

SeanP
Posts: 60
Joined: Wed Sep 01, 2010 11:48 pm
Location: Irvine California

Re: Issue validating field in windows calc app

Post by SeanP » Tue Oct 23, 2012 6:18 pm

This was the line on the validation element

Validating AttributeEqual (Text='2') on item 'Calculator.Text160'.

User avatar
artur_gadomski
Posts: 207
Joined: Mon Jul 19, 2010 6:55 am
Location: Copenhagen, Denmark
Contact:

Re: Issue validating field in windows calc app

Post by artur_gadomski » Wed Oct 24, 2012 8:50 am

Yes it seems like you need to change the RxPath of Text160 to the one I posted.