Issue with indentifying tree elements on Windows 7 64 bit ma

Bug reports.
ishpreet
Posts: 2
Joined: Wed Feb 11, 2015 12:06 am

Issue with indentifying tree elements on Windows 7 64 bit ma

Post by ishpreet » Wed Feb 11, 2015 12:14 am

Hi

We recently migrated from Windows XP to Windows 7 64 bit and I am having trouble identifying objects in tree on 64 bit machine. It works fine on 32 bit.

Note - I tried enabling and disabling '32/64 bit bridge' checkbox. Ranorex spy just can't find it on 64 bit machine. Please help with resolution?

Screenshot of tree attached for reference

Thanks
Ishy
Attachments
Unable to find objects under tree.jpg
Unable to find objects under tree.jpg (184.51 KiB) Viewed 835 times

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Issue with indentifying tree elements on Windows 7 64 bit ma

Post by krstcs » Wed Feb 11, 2015 3:15 pm

Welcome to the forums.

Please include the following information when you raise an issue in the forums:

Version of Ranorex (current is 5.2.2)
Version of Windows
Technology of system under test (HTML, Java, WPF, etc.)


Also, in this case, could you post a Ranorex Snapshot of the application? You can find information about creating a Ranorex Snapshot here. If you cannot post it to the forum, please send it to Ranorex's Support team at [email protected] and reference this thread.

In addition, could you post a RanoreXPath for the element you are trying to find INSIDE the tree?
Shortcuts usually aren't...

ishpreet
Posts: 2
Joined: Wed Feb 11, 2015 12:06 am

Re: Issue with indentifying tree elements on Windows 7 64 bit ma

Post by ishpreet » Wed Feb 11, 2015 6:23 pm

Sure.

Version of Ranorex: 5.2.1.20895
Version of Windows: Windows 7 64 bit
Technology of system under test: .Net Window application

The Ranorex path that i am trying to capture is: /form[@controlname='frmRuleManager']/?/?/tree[@controlname='m_objtreeApplicationView']/?/?/treeitem[@accessiblename='Image Retention Facility']

As mentioned in my previous message, I was able to capture the path on 32 bit machine but it doesn't get recognized in 64 bit machine. Please help! let me know if you need additional information.

Note - I am also attaching snapshot of how the tree looks like in 32 bit.
Attachments
Tree snapshot 32 bit machine.rxsnp
Tree snapshot from my old 32 bit machine
(65.71 KiB) Downloaded 55 times
Snapshot tree view - 64 bit machine.rxsnp
Tree snapshot from my new 64 bit machine
(65.17 KiB) Downloaded 59 times
Unable to find objects under tree- 64 bit machine.jpg
Tree screenshot from my new 64 bit machine
Unable to find objects under tree- 64 bit machine.jpg (184.51 KiB) Viewed 820 times

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Issue with indentifying tree elements on Windows 7 64 bit ma

Post by krstcs » Wed Feb 11, 2015 7:05 pm

Is the application different on 64-bit vs. 32-bit systems?

If so, could it be that the developers did not implement accessibility in the 64-bit version?


Otherwise it appears that this is could be a bug with Ranorex.


Also, have you tried using the XPath from 32-bit Spy in a repository object and seeing if Ranorex can see the element during the test on a 64-bit system? It could be that Spy has a problem but the test doesn't.
Shortcuts usually aren't...