Issue with Ranorex Addon installed on IE

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
hanguyen2009
Posts: 18
Joined: Wed May 27, 2015 9:43 am

Issue with Ranorex Addon installed on IE

Post by hanguyen2009 » Tue Sep 01, 2015 11:31 am

Hi,

When I run Ranorex on server, I got Warning message as :' Please make sure that you have the Ranorex Addon installed and enabled in Internet Explorer. Otherwise Ranorex UI element identification might be very slow.
The following website provides more information on this technology limitation:
http://www.ranorex.com/support/user-gui ... html#c3253"

I checked settings follow guidance on support that fine as files attachement, but this warning message still display every time ranorex running,

Please help to check,

Thanks

Server Info:
Windows Server 2012 R2 Standard
IE 11.0.16
Ranorex 5.4
Attachments
InternerExplorerEnhanced SecurityConfiguration.jpg
InternerExplorerEnhanced SecurityConfiguration.jpg (71.5 KiB) Viewed 2043 times
InternetOption.jpg
InternetOption.jpg (52.88 KiB) Viewed 2043 times
RanorexAddon.jpg
RanorexAddon.jpg (215.25 KiB) Viewed 2043 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Issue with Ranorex Addon installed on IE

Post by Support Team » Mon Sep 07, 2015 10:26 am

Hello hanguyen2009,

The settings in Internet Explorer seem to be correct, but usually the security protection is a little bit more strict on server operating systems.
Please also make sure that the "Enable third-party browser extensions" is enabled.
InternetExplorer.png
InternetExplorer.png (48.25 KiB) Viewed 2004 times
I hope that helps.

Regards,
Bernhard
.
Image