Issues working with multiple test developers in one solution

Ask general questions here.
JimLin
Posts: 38
Joined: Mon Jun 02, 2014 4:23 pm

Issues working with multiple test developers in one solution

Post by JimLin » Wed Sep 02, 2015 4:43 pm

Environment: MS Server 2012r2 VM
Ranorex version: 5.3.2
TFS version: VSO 2013
Visual Studio: Premium 2013

Hi,
I have been the sole tester developing Ranorex tests. Recently however I have had a colleague join me, working on the same Ranorex project. This is causing problems with checkins. These issues result in VS Conflicts and also modules not being copied between checkins. For instance, I can check in a new module in my instance of Ranorex, but when my colleague then does a Get Latest or checks in his own work, that module doesn't always appear in his instance of Rx and causes build errors. Oddly though, we generally we find that the modules have copied across but and I can add them back into the solution on the Rx instance on his machine.

This maybe caused by the way we are doing checkins, but we have had issues doing checkins using Ranorex and also using Visual Studio. Please can someone advise the correct way of doing our checkins and sharing source control as this is becoming more problematic and will be further complicated when I have another colleague join my team in a couple of weeks.

Cheers,
James

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3944
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Issues working with multiple test developers in one solution

Post by odklizec » Wed Sep 02, 2015 4:56 pm

Hi,

I see you are using TFS. My personal experience with TFS is that newly added files (typically Recordings) are sometimes not recognized by "Pending Changes"! So before I perform checkin, I always perform TFS "Compare" between server and local files and all "new" files set manually to "add" to TFS. This should solve your problem with missing (newly added) project files.

As for the conflicts, there is not much you can do with them except to solve them one by one. Some could be solved automatically by TFS, some may need your interaction. You will definitely have to review all of them manually.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

bennylew
Certified Professional
Certified Professional
Posts: 22
Joined: Wed Sep 17, 2014 10:43 am

Re: Issues working with multiple test developers in one solution

Post by bennylew » Wed Sep 02, 2015 5:40 pm

I was facing the same issue. Be sure that you also check in the csproj file. If you miss this, the new module is physicslly on the workspace, but not included into the project.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3944
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Issues working with multiple test developers in one solution

Post by odklizec » Wed Sep 02, 2015 6:26 pm

I'm definitely checking-in csproj file. It's just that TFS sometimes don't recognize new files? It's definitely weird TFS behavior. I never experienced anything like that with SVN.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

JimLin
Posts: 38
Joined: Mon Jun 02, 2014 4:23 pm

Re: Issues working with multiple test developers in one solution

Post by JimLin » Fri Sep 11, 2015 12:13 pm

Hi, sorry for not responding to this thread sooner.

I have done some more investigation into this issue and now have an idea of what is happening during the checkin process in VS and Ranorex and it isn't straight forward (down right peculiar in fact!).

I will post an update once I have a clearer idea and a process that we find works for every checkin.

Cheers,
James