Item could be found using its absolute path but not clicked

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
eric.franc
Posts: 20
Joined: Tue May 05, 2015 11:25 am

Item could be found using its absolute path but not clicked

Post by eric.franc » Fri Jun 09, 2017 6:17 am

Without apparent reason the Ranorex suddenly fails to click an item.

I am using cruise control and the same ranorex build as been used for over 4 months without failure.
Now suddently I get the following error:

7:46.034 Info Mouse Mouse Left Click item 'Open.ButtonExport' at 92;12.
48:16.206 Warn Repository Item 'CTIntegrationRepository.Open.ButtonExport' could be found using its absolute path, but not using its relative path from the cached element of parent folder 'CTIntegrationRepository.Open'. This can happen if either the item search timeout is too small or if items within a rooted folder do not share a common parent element. To fix this problem, first increase the item search timeout. If this does not help, create a separate rooted folder for this item or disable caching for the specified folder.

I can clearly see in the picture that the "export" button is not clicked.

Here is what I get from ranorex spy
/form[@title='Export (testing_export)']/button[@text='&Export']
And here is the path inside ranorex
/form/button[@text='&Export']

Any clue what could happend ?
The issue occurs in TC3_Export. I have included the report.

Thanks,
Attachments
report.zip
report
(304 Bytes) Downloaded 30 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Item could be found using its absolute path but not clicked

Post by odklizec » Fri Jun 09, 2017 8:59 am

Hi,

Please post a Ranorex snapshot of the problematic element. Without the snapshot, there is not much anyone here can do or suggest. My guess is that the xpath is too short/too general so Ranorex has a problem to identify the element? But as mentioned, snapshot is missing (critical) piece of information here.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

eric.franc
Posts: 20
Joined: Tue May 05, 2015 11:25 am

Re: Item could be found using its absolute path but not clicked

Post by eric.franc » Fri Jun 09, 2017 10:49 am

Thanks I am not really familliar with the system.

Here are the snapshot
Attachments
Snapshot.zip
(94.46 KiB) Downloaded 41 times

qwertzu
Posts: 178
Joined: Wed Jan 25, 2017 11:08 am

Re: Item could be found using its absolute path but not clicked

Post by qwertzu » Mon Jun 12, 2017 2:24 pm

Hello eric.franc,

When opening the snapshot of your test machine, a Win32 limitation warning appears which does not appear in the other snapshot.
So please try to start Ranorex and your application with administrator rights and see whether the issue still persists.

If this does not solve the issue, please go through the steps on the following troubleshooting page:
https://www.ranorex.com/support/user-gu ... html#c3252

regards,

qwertzu

kulwinder
Posts: 5
Joined: Tue Jul 04, 2017 5:25 am

Re: Item could be found using its absolute path but not clicked

Post by kulwinder » Wed Jul 05, 2017 6:02 am

Basic Details.rxsnp
(212.66 KiB) Downloaded 26 times
checkboxsnapshot.rxsnp
(166.58 KiB) Downloaded 25 times
Hi,

I have a similar kind of issue with Ranorex 7.1

I am able to identify the element. For instance, when you are doing the right click on the element in the object repository and click on Highlights Element, it is highlighting the right object. However, when I am using that object in the code and using click method, it is giving me the error.

Element #1:
Failed to find item 'HAWKi_Objects_Repository.HAWKiV117072QA.MainFrame.BasicDetails'.
No element found for path '/form[@name='HAWKi - v_1.17.07.2 QA']/container//tabpagelist/tabpage[@automationid='BasicDetails']' within 1.5m.

XPATH: .//tabpagelist/tabpage[@automationid='BasicDetails']

Code: repo.HAWKiV117072QA.MainFrame.BasicDetails.Click();

Element#2:

XPATH: .//tabpagelist/tabpage[@automationid='BasicDetails']/element/tabpagelist/tabpage[@automationid='BasicDetailsTab']/element/element[@automationid='IdentifiedByOptionsList']/list/listitem[1]/checkbox[@name='Building Unit Plan']

Code: repo.HAWKiV117072QA.MainFrame.BuildingUnitPlan.Click();

I am not able to click on that. I would really appreciate for any help in this matter.

Attached are the snapshots.

qwertzu
Posts: 178
Joined: Wed Jan 25, 2017 11:08 am

Re: Item could be found using its absolute path but not clicked

Post by qwertzu » Thu Jul 06, 2017 12:42 pm

Hello kulwinder,

Please try to use the following paths and see whether the issue persists:

Basic Details element:

/form[@classname='Window' and @orientation='None']/container[@automationid='MainFrame']/?/?/tabpage[@automationid='BasicDetails']

Checkbox:

/form[@classname='Window' and @orientation='None']//tabpage[@automationid='BasicDetails']//tabpage[@automationid='BasicDetailsTab']/?/?/element[@automationid='IdentifiedByOptionsList']/list[@automationid='ItemList']/listitem/checkbox[@name='Building Unit Plan']

I hope, this helps.

regards,
qwertzu