Jira integration - Module not found error

Ask general questions here.
MBO
Posts: 1
Joined: Fri Nov 24, 2017 1:25 pm

Jira integration - Module not found error

Post by MBO » Fri Nov 24, 2017 2:02 pm

Hi

I'm trying to integrate Jira into Ranorex v7.2.1, by following a blog. (/blog/integrating-ranorex-test-cases-into-jira/ -> not allowed to post links with a new account)
I'm able to install it via 'manage package' and I can see the entries in the Ranorex Module Browser, as in step 2 of the blog.

But as soon as I try to run a test, I get the following error: The module 'InitializeDefaultConfiguration' (with ID {76ff8843-49b3-4968-9c30-ce917ab28d5e}) could not be found.

In one of the posts at the end of the page, someone else had the same issue and the response was: This usually happens if the .dll, which contains the “modules” is missing in the output folder (which is usually “bin/Debug”).
So please check if the “JiraReporter.dll” file is present in the output folder (or the folder where you’re starting your Ranorex Test suite .exe from).
Please also check the .Net framework used (3.5 is required for the .dlls to work)

Now I can confirm that this dll is missing in the bin/debug folder. But I don't manage to find this dll on my pc or on the internet for download.
The .NET framework is 4.6, so that should be ok.

Anybody any idea what I did wrong or how to solve this issue?
Thanks!

User avatar
Vega
Posts: 109
Joined: Mon Jul 11, 2016 2:15 pm

Re: Jira integration - Module not found error

Post by Vega » Mon Nov 27, 2017 7:59 pm

Hi, I think the comment you are referring to is for an older version of the integration as it is dated from 2015 while the blog post was updated in 2017 (see time stamp at top of page vs comment time stamp). I just followed the blog and the integration worked out of the box; I do not have a 'JiraReporter.dll' in my output folder but do have 'Ranorex_JiraIntegration.dll located at:

C:\Users\<USERNAME>\Documents\Ranorex\RanorexStudio Projects\<SOLUTION NAME>\packages\Ranorex_JiraIntegration.7.1.2.1\lib\net452\Ranorex_JiraIntegration.dll


What I would try if I was you is removing the package and then re-adding it. After adding the package, I see the below references were added:

Atlassian.Jira
Newtonsoft.Json
Ranorex_JiraIntegration <-- This one contains the modules
RestSharp

Here is what Ranorex_JiraIntegration looks like upon further inspection:
jira2.png
jira2.png (24.06 KiB) Viewed 293 times
Are you getting any warnings or errors while building?