KeyPass Test Failed

Ask general questions here.
gary
Posts: 17
Joined: Thu Sep 22, 2016 2:52 pm

KeyPass Test Failed

Post by gary » Thu Sep 22, 2016 3:05 pm

Hi There

We as a company have recently intalled the evaluation version (30 day trial).

I was following the instruction for the KeyPass test. When I tried to run the KeyPass test after automating it stuck at below stage and failed eventually:
Open the 'Add new Entry' Form.
Click on 'Edit' in the main tool bar
Click on the 'Add Entry' menu item
I was watching the test all the time and it seems that the Ranorex identified the menu item 'Edit' but did not performed the clicked action on 'Add Entry'. Can you please explain the reason why ? Also is there a possible way to sort out this issue ? Thanks

Regards
Gary

User avatar
RobinHood42
Posts: 239
Joined: Fri Jan 09, 2015 3:24 pm

Re: KeyPass Test Failed

Post by RobinHood42 » Fri Sep 23, 2016 1:36 pm

Hi Gary,

Do you get an error message when running the test? On the Ranorex Studio start page you can load some sample projects. The desktop sample contains a test for the KeePass application. Do you have problems running this test?

Cheers,
Robin

gary
Posts: 17
Joined: Thu Sep 22, 2016 2:52 pm

Re: KeyPass Test Failed

Post by gary » Fri Sep 23, 2016 1:42 pm

RobinHood42 wrote:Hi Gary,

Do you get an error message when running the test? On the Ranorex Studio start page you can load some sample projects. The desktop sample contains a test for the KeePass application. Do you have problems running this test?

Cheers,
Robin
Hi Robin

| don't get the error message but the test fails bcoz the script says click on the 'Add Entry' menu item but when the test runs it does not click on the specified menu item in the script.

Thanks

User avatar
RobinHood42
Posts: 239
Joined: Fri Jan 09, 2015 3:24 pm

Re: KeyPass Test Failed

Post by RobinHood42 » Fri Sep 23, 2016 1:53 pm

Hi,

Did you run the sample project? Do you also see the problem there?

Cheers,
Robin

gary
Posts: 17
Joined: Thu Sep 22, 2016 2:52 pm

Re: KeyPass Test Failed

Post by gary » Fri Sep 23, 2016 2:00 pm

RobinHood42 wrote:Hi,

Did you run the sample project? Do you also see the problem there?

Cheers,
Robin
No I didn't run the sample project but I experience similar issues with the test I've created for our internal application.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: KeyPass Test Failed

Post by Support Team » Mon Sep 26, 2016 3:37 pm

Hello gary,

As Robin wrote, this might have different reasons. The most common reason is that the control is not fully loaded when Ranorex performs a click on this element. Do you execute the test on a virtual machine? If yes, maybe the vm doesn't have enough resources or is just slow. Please check if you have the same problem when running the test on another machine.
I was not able to reproduce this issue on my machine with the KeePass application. Is it possible for you to provide a sample solution in order to show us what exactly doesn't work?
If you don't want to post your solution in our forum, you can also send an email to [email protected].

Regards,
Bernhard
.
Image

gary
Posts: 17
Joined: Thu Sep 22, 2016 2:52 pm

Re: KeyPass Test Failed

Post by gary » Mon Sep 26, 2016 3:47 pm

Support Team wrote:Hello gary,

As Robin wrote, this might have different reasons. The most common reason is that the control is not fully loaded when Ranorex performs a click on this element. Do you execute the test on a virtual machine? If yes, maybe the vm doesn't have enough resources or is just slow. Please check if you have the same problem when running the test on another machine.
I was not able to reproduce this issue on my machine with the KeePass application. Is it possible for you to provide a sample solution in order to show us what exactly doesn't work?
If you don't want to post your solution in our forum, you can also send an email to [email protected].

Regards,
Bernhard
Hi Bernhard

Thank you for your response.
Yes I am executing the test on virtual machine. I'll try executing on different machine (if possible).
Sorry I am relatively new with Ranorex, how do I go about providing you the sample solution ? Thanks

Regards
Gaurav

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: KeyPass Test Failed

Post by Support Team » Thu Sep 29, 2016 5:19 pm

Hello Gaurav,

Thank you for getting back to me. With sample solution I mean a small Ranorex solution showing the issue. In order to get a detailed description how to create a compressed Ranorex Solution please read the section "How To Create A Compressed Ranorex Solution" on our website.

Regards,
Bernhard
.
Image

gary
Posts: 17
Joined: Thu Sep 22, 2016 2:52 pm

Re: KeyPass Test Failed

Post by gary » Tue Nov 01, 2016 9:25 am

gary wrote:
Support Team wrote:Hello gary,

As Robin wrote, this might have different reasons. The most common reason is that the control is not fully loaded when Ranorex performs a click on this element. Do you execute the test on a virtual machine? If yes, maybe the vm doesn't have enough resources or is just slow. Please check if you have the same problem when running the test on another machine.
I was not able to reproduce this issue on my machine with the KeePass application. Is it possible for you to provide a sample solution in order to show us what exactly doesn't work?
If you don't want to post your solution in our forum, you can also send an email to [email protected].

Regards,
Bernhard
Hi Bernhard

Thank you for your response.
Yes I am executing the test on virtual machine. I'll try executing on different machine (if possible).
Sorry I am relatively new with Ranorex, how do I go about providing you the sample solution ? Thanks

Regards
Gaurav
Hi Bernhard

I was wondering how do I provide a sample solution on this forum and what should it contain ?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: KeyPass Test Failed

Post by Support Team » Thu Nov 03, 2016 3:02 pm

Hello Gaurav,

A sample solution is a small Ranorex Solution which show the issue. Just create a new Ranorex Solution and add the steps which are failing into a recording.
You can send the the compressed Ranorex solution file to [email protected].

I hope this answers your question.

Regards,
Bernhard
.
Image