Latest version of Ranorex support Java Swing?

Ask general questions here.
ModelingPaul
Posts: 13
Joined: Thu Apr 05, 2018 10:46 pm

Latest version of Ranorex support Java Swing?

Post by ModelingPaul » Mon Apr 23, 2018 7:14 pm

Does the latest version of Ranorex support Java Swing or do I need to have the plugin? One of the webpages seemed to imply a plugin was still needed.

If so, can you point me to a link?

Thanks!

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3944
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Latest version of Ranorex support Java Swing?

Post by odklizec » Tue Apr 24, 2018 7:18 am

Hi,

Ranorex supports Java Swing for a very long time. There is no need to install anything extra. All required plurins are a part of Ranorex installation package. The best you can do is to try Ranorex with your app.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

ModelingPaul
Posts: 13
Joined: Thu Apr 05, 2018 10:46 pm

Re: Latest version of Ranorex support Java Swing?

Post by ModelingPaul » Tue Apr 24, 2018 3:17 pm

I currently use 6.1.1 (which does not support Java Swing unless it was not installed correctly by my IT folks) while we are waiting for 8.1 to get approved to be installed on our classified network. That is why I asked.

Thanks for the reply

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3944
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Latest version of Ranorex support Java Swing?

Post by odklizec » Wed Apr 25, 2018 11:23 am

Hi,

I'm not sure I understand this:
"which does not support Java Swing unless it was not installed correctly by my IT folks"
Installed correctly what? Ranorex or the the Java Swing app?
I'm pretty sure that Ranorex 8 (7 probably too) does not need any separate Java Swing plugin. In other words, all required plugins (for supported technologies) are a part of Ranorex installation package. Of course, there may be some custom-made UI elements, which are not recognized by Ranorex. Unfortunately, it's impossible to tell if all elements in your app will be recognized as expected, without examining your app under test.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

ModelingPaul
Posts: 13
Joined: Thu Apr 05, 2018 10:46 pm

Re: Latest version of Ranorex support Java Swing?

Post by ModelingPaul » Wed Apr 25, 2018 7:57 pm

All I mean by that is if there was a plugin that allowed v6.1.1 to work with Java Swing that was not installed when v6.1.1 was installed on my box.

No big deal...hopefully I can 8.1 very soon.

Thanks for the replies!

bselderhuis
Posts: 1
Joined: Mon Jul 02, 2018 2:30 pm

Re: Latest version of Ranorex support Java Swing?

Post by bselderhuis » Mon Jul 02, 2018 2:37 pm

Does version 8.0.1 support Java Swing?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Latest version of Ranorex support Java Swing?

Post by Support Team » Tue Jul 03, 2018 4:58 pm

bselderhuis wrote:Does version 8.0.1 support Java Swing?
Hi Bselderhuis,

Yes, Ranorex 8.0.1 fully supports Java Swing. For a full list of supported technologies, click here.

Cheers,
Ned
.
Image