License Manager couldn't be contacted after executing test

Ask general questions here.
xeronar
Posts: 28
Joined: Mon May 22, 2017 8:19 pm

License Manager couldn't be contacted after executing test

Post by xeronar » Tue Jul 25, 2017 9:15 am

Ranorex version: 7.1
OS: Windows Server 2012 R2
License Server: FOX

Hi everyone,

I have two test servers, one being my "master" A with Ranorex Studio (floating license) and the other one (B) being the "slave" with a Ranorex Agent and a runtime license.

In order to test CI we've installed an Octopus Tentacle on B and triggered the deployed test. The test data contain

- the bin/Debug folder from my test project
- all the .dll files you need to run the test without Ranorex Studio as per https://www.ranorex.com/help/latest/les ... test-suite "...you need to ensure that the library (*.DLL) files are also part of the same directory. In short, to deploy a Ranorex test to a runtime machine it's required to copy the complete output folder (e.g. 'bin/debug') to the target machine."
- the license file Ranorex3_Server.lic

After executing my test via a Selenium Endpoint on B, i was not able to start Ranorex Studio on A, the Ranorex Agent on B couldn't find the license server as well and set the license server to A for some weird reasons. During this process, I was signed in on A but Ranorex Studio wasn't running. The command was simply

Code: Select all

test.exe /ep:SeleniumEndpoint
So I deleted all the files (the license file included) on B, signed out and in on both servers, I've even restarted them, but they still can't find the License Server FOX. I pinged the server via "Configure Ranorex License", but it failed.

Are there any connection problems to the license servers in general? If not, what do I have to do to get Ranorex Studio and the Agent running again?

xeronar
Posts: 28
Joined: Mon May 22, 2017 8:19 pm

Re: License Manager couldn't be contacted after executing test

Post by xeronar » Tue Jul 25, 2017 9:49 am

It might be done already, my admins are currently struggling with issues on exactly the servers I'm running my tests, so I'll have to wait first. Sorry for my panicing :D

EDIT: The issues are solved and i can run Ranorex as usual. Thread can be closed now.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: License Manager couldn't be contacted after executing test

Post by Support Team » Wed Jul 26, 2017 8:43 am

Hi xeronar,

I'm glad, that you could resolve the issue.

Sincerely,
Robert
.
Image