LineageGlueRule 'chrome_web_child_elements' caused RanorexException on Execute

Ranorex Spy, Recorder, and Studio.
prepelra
Posts: 10
Joined: Tue Apr 02, 2019 9:33 am

LineageGlueRule 'chrome_web_child_elements' caused RanorexException on Execute

Post by prepelra » Mon Apr 15, 2019 3:29 pm

I get this error message:

"LineageGlueRule 'chrome_web_child_elements' caused RanorexException on Execute "

This is happening only on some pages, not on all. Any idea? It seems to be a Ranorex issue, because the same script, is working correctly on other pages from the website that I test.

My Ranorex version is 9.0.0+git.2.a79532e. I use the 64 exe file.

Chrome is a german version 73.0.3683.103 (Offizieller Build) (64-Bit)

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5066
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: LineageGlueRule 'chrome_web_child_elements' caused RanorexException on Execute

Post by odklizec » Tue Apr 16, 2019 7:29 am

Hi,

At first, please update your Ranorex version with most recent 9.0.1, which corrects a lot of 9.0.0 bugs, including some Chrome plugin related issues. Please make sure to first completely uninstall Ranorex 9.0 before installing 9.0.1! After installing new version, Chrome plugin should state version 1.2.6 (Chrome >> More Tools >> Extensions).

If the problem continue to happen even after reinstalling Ranorex and chrome plugin, which happened to me as well, I would suggest to uninstall Chrome plugin via Ranorex instrumentation wizard. Then go to Chrome, create new user profile and delete the existing one. Then with Ranorex instrumentation wizard, install Ranorex plugin for Chrome.

If the problem still happens, go to Ranorex settings (Plugins tab >> Web section ) and try to set the Enable JS-based RanoreXpath evaluation to false.

If everything I mentioned fails to fix your problem, please contact Ranorex support via their support form and request a remote session with them.

Hope this helps?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

prepelra
Posts: 10
Joined: Tue Apr 02, 2019 9:33 am

Re: LineageGlueRule 'chrome_web_child_elements' caused RanorexException on Execute

Post by prepelra » Tue Apr 16, 2019 2:11 pm

Hi,

I have done all your steps. Same behavior.

LineageGlueRule 'chrome_web_child_elements' caused RanorexException on
Execute. Message timeout reached.

:(