LineageGlueRule "java_web" exception RNRX4.0

Bug reports.
krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

LineageGlueRule "java_web" exception RNRX4.0

Post by krstcs » Wed Dec 12, 2012 5:39 pm

I am seeing a LineageGlueRule exception being thrown for "java_web" with Ranorex 4.0.

I have deleted all ProgramData folders for Ranorex 3, but still get the issue.

EDIT TO ADD: OK, dropped reporting to debug level and now I have the following in the report:
**************************************************************************************
"LineageGlueRule 'java_web' caused NullReferenceException on Execute. Object reference not set to an instance of an object.

at Ranorex.Plugin.JavaWebRule.CreateApplet(GlueRuleExecutionState state) at Ranorex.Plugin.JavaWebRule.Execute(GlueRuleExecutionState state) at Ranorex.Core.ElementEngine.ApplyGlueRules(Element element, GlueRuleExecutionState state)"
**************************************************************************************

Again, this isn't stopping my test, but it should not be displayed.

This happens on both my development system with Ranorex 4 Pro, and my test system (VBox VM) with Ranorex 4 Runtime.

Both are Windows 7 x64.

The system under test is Silverlight 4, with no Java on the front-end (I assume that the java_web reference is for Javascript...).
Shortcuts usually aren't...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: LineageGlueRule "java_web" exception RNRX4.0

Post by Support Team » Thu Dec 13, 2012 12:40 pm

Hello,

Thank you for reporting that issue.
Are you using Java (e.g. to access a web service) within your Silverlight application?
Are there some other java programs opened on your machine?

In order to reproduce this issue it would be helpful to get access to your application or to get a sample application.

Regards,
Markus (T)
.
Image

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: LineageGlueRule "java_web" exception RNRX4.0

Post by krstcs » Thu Dec 13, 2012 4:17 pm

Due to the nature of our application and the contract with the customer, I am not a liberty to release the application or a snapshot of it.

I do have a Websphere server running in the background (runs on Java), but the front-end interface, which is where Ranorex is working, does not have any Java in it, it is pure Silverlight.

This appears to only happen on interactions with the Silverlight container, but it happens with every interaction with anything inside that container.

I am working on re-producing the problem in a generic application that will allow you to verify the issue.
Shortcuts usually aren't...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: LineageGlueRule "java_web" exception RNRX4.0

Post by Support Team » Thu Dec 13, 2012 5:01 pm

Hello,

Thank you for your info.
Please send your generic application to [email protected].

Thank you in advance.

Regards,
Markus (T)
.
Image

User avatar
larch2012
Posts: 2
Joined: Tue Oct 09, 2012 10:44 pm

Re: LineageGlueRule "java_web" exception RNRX4.0

Post by larch2012 » Mon Dec 17, 2012 10:28 pm

I am seeing this error since upgrading to 4.0.0 as well. My application is flash/java via a browser.

LineageGlueRule 'java_web' caused NullReferenceException on Execute. Object reference not set to an instance of an object.

Anyone else seeing this or have a resolution/workaround would be great!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: LineageGlueRule "java_web" exception RNRX4.0

Post by Support Team » Tue Dec 18, 2012 9:21 am

Hello,

This is a bug in Ranorex 4.0. It will be fixed in our next release, which is planned to be released in the next few days.

Regards,
Bernhard
.
Image