Loading of the "View Test Suite" Tab takes much longer

Bug reports.
Christoph
Posts: 23
Joined: Wed Jul 11, 2012 6:22 am
Location: Liechtenstein

Loading of the "View Test Suite" Tab takes much longer

Post by Christoph » Thu Nov 13, 2014 9:14 am

Hi,

I'm using Ranorex Verison 5.2.0.

With this new version I made following observation: Loading of the "View Test Suite" Tab takes much longer than in previous versions. While loding the page the cursor toggles between normal cursor and "working in background" (see screenshot). Actually the sand clock flickers.
Ranorex.jpg
Ranorex.jpg (18.08 KiB) Viewed 855 times
Steps to produce:
- Start Ranorex
- Open Projekt Solution
- Close all Tabs
- [Click] "View Test Suite"
--> The tab loads, but for quite a while the cursor toggles between normal and working in progress. The time probalby depends on the numer of projects in the solution.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Loading of the "View Test Suite" Tab takes much longer

Post by Support Team » Fri Nov 14, 2014 2:32 pm

Hi Christoph,

We haven't heard about such an issue yet.
Does you see this issue with each solution or just with a specific one?
If you just see this with a specific one may I ask you to send us your solution (to [email protected])?
This would allow us to reproduce this issue on our machines.

Thanks,
Markus
.
Image

Christoph
Posts: 23
Joined: Wed Jul 11, 2012 6:22 am
Location: Liechtenstein

Re: Loading of the "View Test Suite" Tab takes much longer

Post by Christoph » Mon Nov 17, 2014 8:01 am

Hi Makus,

Thanks for your reply. It happens also with other solutions.

I meanwhile found out what causes this behaviour: Ranorex determines the number of rows in each databinding. When the flickering is done behind each data binding that number of rows is displayed.
It is probably related to this "general changes / feature" in verison 5.2.0:

- Data sources are now loaded in the background within the test suite view"

We have quite a number of data sources in this solution and every time I load the test suite view I wait for 20 seconds until I can go on working. This is too long and very annoying.

Christoph

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Loading of the "View Test Suite" Tab takes much longer

Post by Support Team » Tue Nov 18, 2014 1:28 pm

Hi Christoph,

Could you therefore send us your Ranorex solution to [email protected]?
This will allow us to analyze this issue in detail and ease up communication.

Thanks,
Markus
.
Image

Christoph
Posts: 23
Joined: Wed Jul 11, 2012 6:22 am
Location: Liechtenstein

Re: Loading of the "View Test Suite" Tab takes much longer

Post by Christoph » Thu Nov 20, 2014 11:53 am

Hi,

Ranorex analysed the problem and came up with this, which works for us:

- The problem depends on the Office version used for the data connectors: With office 2010 the behaviour is observed, with Office 2013 not, because it works much faster
- the problem might get fixed in Ranorex Version 5.3
- work acound: for each data source the option "Auto-load Data when Test Suite Opens" needs to be disabled.
Solution.jpg
Solution.jpg (69.91 KiB) Viewed 795 times
Thanks Markus for your off line support and workaround.

Christoph