loss of communication with smartphone

Bug reports.
legrand
Posts: 5
Joined: Wed Jul 15, 2015 3:32 pm

loss of communication with smartphone

Post by legrand » Wed Jul 15, 2015 4:03 pm

Steps to reproduce:
- connect smartphone via USB port to PC
- start a test case
- communication is lost between smartphone and Ranorex during the test case procedure
- we get an error message (timeout)
- we notice the device is in status ''connecting'' in the down right windows

we tried to increase time-out to 60s.
we tried another usb port or cable

this behaviour appears in the newest version 5.4.
It was ok in the version 5.3

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: loss of communication with smartphone

Post by Support Team » Thu Jul 16, 2015 2:51 pm

Hi legrand,

May I ask you to also post the following details?
[*]Which mobile OS version are you using?
[*]What is the exact error message?
[*]Which timeout in specific have you increased?
[*]Have you also tried to connect to the device by using Wifi, since this is normally much faster?

Thank you in advance for the details, they will help us in analyzing the issue.

Regards,
Markus
.
Image

legrand
Posts: 5
Joined: Wed Jul 15, 2015 3:32 pm

Re: loss of communication with smartphone

Post by legrand » Fri Jul 17, 2015 8:42 am

Hi Support Team,

The smartphone features are :
- Type : HTC One X
- Android version : 4.2.2

Error message : Device WaitFor(Device connected) Timed out
Timeout increased : Mobile\ Connect Timeout

PS : Sorry , but we've not tried connecting smartphone via wifi... We'll try !!

Kind regards

legrand

legrand
Posts: 5
Joined: Wed Jul 15, 2015 3:32 pm

Re: loss of communication with smartphone

Post by legrand » Fri Jul 17, 2015 10:55 am

Info

WIFI connection is OK...
Keep in touch

Kind regards

legrand

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: loss of communication with smartphone

Post by Support Team » Mon Jul 20, 2015 3:36 pm

Hi Legrand,

That's good news that it works via WIFI.

May I also ask you if it works when you execute the same test a second time?
Could it be that you reseted or established another adb connection to the device with another tool before you start the Ranorex test?
How many adb processes do you see in the task manager when you start the Ranorex test?

Regards,
Markus
.
Image

maneesh_kabra
Posts: 1
Joined: Mon Dec 28, 2015 12:43 pm

Re: loss of communication with smartphone

Post by maneesh_kabra » Mon Dec 28, 2015 1:09 pm

Hi All,

Even I faced this issue with USB (With wifi I didn't try). Here is my scenario:
1. Run MobileApp with API
Host.Local.RunMobileApp(MobileName, appName, true);

2. CLose Appliaction with API
Host.Local.CloseApplication(AppRepository.Self);

3. Again Run MobileApp with API
Host.Local.RunMobileApp(MobileName, appName, true);

Please Note here MobileName and appName are same in both first and third step.

Details- Samsung Galaxy Mobile(Android Version 5.1.1),Ranorex 5.4.1

Let me know if there is issue in my approach or provide the way to deal with this

Regards,
Manish

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: loss of communication with smartphone

Post by Support Team » Wed Dec 30, 2015 11:02 am

Hello,

The 'ConnectTimeout' issue was reproducible on our Android device. We are currently analyzing the issue.

In the meantime, as a workaround, I'd suggest connecting the device via WiFi, which is more reliable.

I will update this forum entry as soon as I have new information about the issue.

Regards,
Johannes
.
Image