Lots of excel processes generated after test finished

Ask general questions here.
monkey2012
Posts: 77
Joined: Wed Sep 26, 2012 8:15 pm

Lots of excel processes generated after test finished

Post by monkey2012 » Thu Jan 22, 2015 4:47 pm

Hi Support Team,

I've been seeing lots of EXCEL.EXE processes generated after test completed but only occured to the first run right after launching Ranorex Studio; the subsequent runs are a lot faster.
During the excel.exe generation, I can't use Ranorex at all; in my case, this takes about 1/2 hours to stop.
Is there an option I can use so this won't happen?
I only use Excel as data connectors

Ranorex Version: 5.2.2 (same to 5.2.1)
OS: Windows 7 32 bits

Thanks

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Lots of excel processes generated after test finished

Post by odklizec » Thu Jan 22, 2015 5:43 pm

Hi,

The number of Excel processes should be equal to number of data connectors in your test suite. Creating one Excel process per data connector is unfortunately necessary (see this post).

I guess there are too many data connectors in your test suite? By default, all data connectors are loaded during the test suite opening. And this may explain the initial slow start. Luckily, there is an option to disable auto-loading of data connectors during loading of test suite. Just uncheck "Auto-Load Data on Test Suite Opening" available in the "Manage Data Sources" dialog. For more details, check this chapter in Ranorex user guide...
http://www.ranorex.com/support/user-gui ... -file.html

Hope this helps?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

monkey2012
Posts: 77
Joined: Wed Sep 26, 2012 8:15 pm

Re: Lots of excel processes generated after test finished

Post by monkey2012 » Thu Jan 22, 2015 5:54 pm

Unchecking "Auto-Load Data when Test Suite Opens" only applies when you open the test suite; and in my case, this is always unchecked; and yes, I have many data connectors since my project is huge.

Is there any other option?

Thanks

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Lots of excel processes generated after test finished

Post by krstcs » Thu Jan 22, 2015 6:01 pm

As Pavel said, this is unfortunately the way it works. Each Excel connector must open a corresponding Excel process.

You could move to a SQL Server Express database instead and import each Excel sheet in as a table in the DB.
Shortcuts usually aren't...

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Lots of excel processes generated after test finished

Post by odklizec » Thu Jan 22, 2015 8:42 pm

monkey2012 wrote:Unchecking "Auto-Load Data when Test Suite Opens" only applies when you open the test suite; and in my case, this is always unchecked;
This is weird. If this option is unchecked (for each data connector in your test suite), then the data connectors should not be loaded during the test suite loading and so the Ranorex studio should not be"locked". This sounds like a bug in Ranorex, unless you forgot to examine some test cases with associated data connectors? ;)

Please recheck all your test cases with associated data connectors, if they all have disabled auto-loading. If there are still started some excel processes, during the test suite loading, then some data connectors are most probably still auto-loaded. Unfortunately, there is probably no "general switch", which would globally disable auto-loading for all data connectors. But I may be wrong? If there is no such functionality, it maybe a good point for feature request?

Aside using DB connectors, as suggested by krstcs, the only other option left to try is using csv data connector? CSV file is more or less plain text file, which does not require excel for its run. However, if your data files are too big, it may still take some significant time to load them.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

monkey2012
Posts: 77
Joined: Wed Sep 26, 2012 8:15 pm

Re: Lots of excel processes generated after test finished

Post by monkey2012 » Fri Jan 23, 2015 3:06 pm

Hi Pavel,

Since I knew that option, I always uncheck that box when I create a data connector and all of them are unchecked, and so, I have no problem opening a test suite at all.
I use Excel because there are many restrictions that I have to follow and there are lots of data to test, plus I use lots of formulas so it is less work once I need to update test data based on requirements.

Thanks

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Lots of excel processes generated after test finished

Post by odklizec » Fri Jan 23, 2015 3:42 pm

Hi,

Sorry, I must have misunderstood you. I thought you have a problem with Ranorex "freeze" while opening the test suite, but now I see the problem is the "lock" during the first test suite run, while all necessary data connectors are created/loaded? Well, I'm afraid, there is probably nothing you can do about it, maybe except replacing the existing data connectors with user code based connectors? I never did such a thing but this way you should be able to load them on demand? But I doubt this workaround will be as easy to implement as creating data connectors via Ranorex Studio ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Lots of excel processes generated after test finished

Post by Support Team » Fri Jan 23, 2015 3:57 pm

Hi monkey2012,

I also don't think that there is a bug, because you have no problems opening the test suite :-).
However, there is another possibility instead of using an SQL data source.
Instead of using the default Excel file format xlsx for your test data you can also use the native binary file format xlsb. This file format much faster than the non-binary version.

Please take a look at the following link.
http://www.ranorex.com/support/user-gui ... html#c8202

This should help to get a better performance.

Regards,
Bernhard
.
Image