Mass flow of uncatched ElementNotFoundExceptions

Bug reports.
User avatar
DirkB
Posts: 19
Joined: Thu Jan 29, 2009 9:53 am

Mass flow of uncatched ElementNotFoundExceptions

Post by DirkB » Thu Jul 15, 2010 10:25 am

Hi,

I don't catch occurring Ranorex.ElementNotFoundExceptions immediately
but with a general surrounding catch (Exception e).
So during a long test run there are hundreds of such exceptions.

Problem: After some time Ranorex doesn't recognize anything anymore.
Questions:
Could there be a problem with Ranorex when there are too many of these ElementNotFoundExceptions?
Is there a better way to circumvent these Exceptions programatically?

My test setup:
Using my own .Net Testrunner GUI I coded several keyword based testfunctions:
e.g. Save_Program which uses several Ranorex.Button = <xpath> of the test object.
Some of the test object's GUI elements might not be visible all the time which is ok so far.
If one GUI element is not available I just take another visible one.

Best regards
Dirk

User avatar
Support Team
Site Admin
Site Admin
Posts: 12169
Joined: Fri Jul 07, 2006 4:30 pm
Location: Houston, Texas, USA
Contact:

Re: Mass flow of uncatched ElementNotFoundExceptions

Post by Support Team » Mon Jul 19, 2010 12:34 pm

Hi,

Sorry for the late response. We are currently trying to reproduce your behavior and we will inform you about the outcome.

Regards,
Peter
Ranorex Support Team

User avatar
Support Team
Site Admin
Site Admin
Posts: 12169
Joined: Fri Jul 07, 2006 4:30 pm
Location: Houston, Texas, USA
Contact:

Re: Mass flow of uncatched ElementNotFoundExceptions

Post by Support Team » Mon Jul 19, 2010 4:04 pm

Hi,

Sorry, but we were not able to reproduce the problem. Would it be possible to send us a short sample application with a Ranorex Project where this error occurs. Or can you describe us the steps to reproduce in more detail (a step by step description would be nice :D ).

Thanks in advance.
Regards,
Peter
Ranorex Support Team

User avatar
DirkB
Posts: 19
Joined: Thu Jan 29, 2009 9:53 am

Re: Mass flow of uncatched ElementNotFoundExceptions

Post by DirkB » Mon Aug 02, 2010 12:15 pm

Hi Peter,

unfortunately this behaviour is hard to reproduce.
It takes hours to show up the failure.
My post was intended to just ask a question about the proper implementation for these try-catches and to give a hint if there might be a long-time problem with these exception.

If I can find a simple setup to reproduce this failure I certainly will inform you.

Meantime please feel free to invest your time somewhere else :wink:
Regards
Dirk