maximized Flag doesn't work for Firefox and Chrome

Bug reports.
reiniuny
Posts: 23
Joined: Thu Jul 04, 2013 10:48 am

maximized Flag doesn't work for Firefox and Chrome

Post by reiniuny » Wed Jul 10, 2013 1:50 pm

I'm testing an application for multiple browsers with the following code:

Code: Select all

Host.Local.OpenBrowser(url, browser, "", false, true);
The string "browser" is either "ie", "Firefox" or "Chrome".

As the tested application needs to be run in a maximized window, I've set the parameter "maximized" to true.

Unfortunately only IE opens always in a maximized window, Firefox and Chrome are just run as they have been closed - if the last state wasn't maximized, the browser window keeps staying small.

I'm running Ranorex v4.0.5, Windows 7 x64 SP1, IE9, Firefox 22 and Chrome 27.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: maximized Flag doesn't work for Firefox and Chrome

Post by Support Team » Thu Jul 11, 2013 2:40 pm

Hello,

It looks like that the browser process is still running when you try to use OpenBrowser().
Could you please verify that Firefox/Chrome process is not running in the Task Manager and kill this process? Then, your method should work as expected.

Regards,
Markus (T)
.
Image

reiniuny
Posts: 23
Joined: Thu Jul 04, 2013 10:48 am

Re: maximized Flag doesn't work for Firefox and Chrome

Post by reiniuny » Fri Jul 12, 2013 6:11 am

Hi Markus,
you are right, Firefox was still running and Chrome was hiding in system tray :shock:

I've tried it with enabling "killExisting" flag and now it works perfectly.

Thank you!