Microsoft Edge

Bug reports.
Yaman
Posts: 1
Joined: Wed Sep 16, 2020 1:20 am

Microsoft Edge

Post by Yaman » Wed Sep 16, 2020 1:29 am

J'ai 2 problèmes

1: Je n'arrive pas à ouvrir Edge en mode private même si j'ai le mode incognito à true
Host.Current.OpenBrowser(UrlBuilt, BrowserToOpen, "", false, false, false, true, false, true);

2: J'ai une variable sur le Dom Base
/dom[@domain=$DomainToTest and @visible='True']
mais Edge ne reconnait pas le domaine à tester
edge.png
edge.png (35.52 KiB) Viewed 40 times
par contre tout fonctionne bien avec Chrome, firefox et IExplorer

******************************************************************

I have 2 problems

1: I can't open Edge in private mode even if I have incognito mode set to true
Host.Current.OpenBrowser (UrlBuilt, BrowserToOpen, "", false, false, false, true, false, true);

2: I have a variable on the Dom Base
/ dom [@ domain = $ DomainToTest and @ visible = 'True']
but Edge does not recognize the domain to test
[attachment = 0] edge.png [/ attachment]
on the other hand everything works well with Chrome, firefox and IExplorer

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6180
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Microsoft Edge

Post by odklizec » Fri Sep 18, 2020 7:42 am

Hi,

As for the first problem, it really looks like a bug/not implemented feature in OpenBrowser action? I would suggest to contact directly Ranorex support about this:
https://www.ranorex.com/support-query/

As for the second problem, if the same action and domain works with other browsers, then there are two possible reasons...
1) MSEdge is not properly instrumented or the instrumentation is corrupted. You can quickly check this by tracking a web page in MSEdge, using a Ranorex Spy tool. Does it see DOM? If there is visible just a bunch of forms and element, but not DOM, it's because of not installed/corrupted Ranorex plugin. Try to instrument it again.

2) MSEdge is not listed in Ranorex whitelist. This could have the same effect, as not instrumented/corrupted instrumentation. Spy will simply not be able to see or track anything in MSEdge window, not even forms! You will have to add MSEdge process name to Ranorex whitelist.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration