missing attributes in Path Editor

Bug reports.
User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

missing attributes in Path Editor

Post by odklizec » Mon Aug 26, 2013 4:33 pm

I believe I found a bug in Path Editor in RX 4.1. I found the problem while fiddling with another issue regarding the Path Weight editing (missing Dynamic capabilities).

It seems that after switching between the path elements, some of the GUI attributes are not displayed in the attribute list. A manual refresh is required to display those "missing" attributes, which is quite annoying if one needs to repeat this action after each element selection.

Here is an example snapshot:
Toolbar.rxsnp
(7.6 KiB) Downloaded 156 times
Steps to reproduce:
- load the attached snapshot >> a "Toolbar" element should get selected
- switch from Browser to Path Editor >> there should be listed General, NativeWindow and Dynamic capabilities
- now select the root element "form" >> now it shows just General, FormTag and Form
- press Refresh >> NativeWindow and Dynamic are added!
- select "toolbar" element >> now it shows just General capabilities
- press Refresh >> NativeWindow and Dynamic are added

Here are screenshots to the above steps:
PathEditor_missing_attributes.png
PathEditor_missing_attributes.png (107.54 KiB) Viewed 998 times
Hope this helps?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: missing attributes in Path Editor

Post by Support Team » Tue Aug 27, 2013 3:28 pm

Hello,

Thank you for the detailed description.
I added an issue in our bug tracking system. We will analyze the issue as soon as possible.
Thank you!

Regards,
Bernhard
.
Image