Missing data bindings after saving and reopening solution

Ranorex Spy, Recorder, and Studio.
nico
Posts: 24
Joined: Tue Nov 04, 2014 3:13 pm

Missing data bindings after saving and reopening solution

Post by nico » Fri Nov 13, 2015 11:24 am

Yesterday I saved my solution and when I reopened the solution today, I am missing all my data bindings.
I have all the variables, I have all my parameters. But none of them are binded anymore.

Very annoying since it are over 300 variables that need to be re-binded.

Working with Ranorex 5.4.1.25490
.NET 4.0.30319.1026
On Windows Server 2008

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Missing data bindings after saving and reopening solution

Post by odklizec » Fri Nov 13, 2015 2:24 pm

This should definitely not happen. Unfortunately, it's hard to tell what caused it. I would suggest to send corrupted solution to Ranorex support. Maybe they can find what's wrong and eventually fix your solution?

Anyway, you should be able to restore last good state from version control system? I hope you are using one? Because if not, you should start right away! Version control system is an important part of any development, including test automation development.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration