Missing headers

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
seurrep
Posts: 17
Joined: Tue Aug 07, 2018 10:19 am

Missing headers

Post by seurrep » Wed Sep 12, 2018 11:07 am

I'm using a code method to post something via HTTP. This is supposed to return a response that includes some JSON and headers. The JSON is returned. Even most of the headers are, except for some reason X-CorrelationID, Receipt-ID, Receipt-Timestamp & Receipt-Signature. These last four headers are missing.

Running Fiddler in the background shows that the missing headers are actually being returned. Knocking up my own mickey mouse application in Visual Studio to just do that one task using the code from my Ranorex code library also returns the headers.

The question then is why can't Ranorex see them or let me check them? Am I missing something?

Am currently running Ranorex 8.2.1+git.2cdaf795.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Missing headers

Post by odklizec » Thu Sep 13, 2018 8:38 am

Hi,

I'm afraid, there is not much anyone here can do without seeing your code and even better, a real sample solution with simple HTTP post/get methods you are using. Could you please post such sample solution?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration