Mouse cursor not visible during test recording when overridi

Ask general questions here.
erikiknl
Posts: 2
Joined: Wed Nov 01, 2017 9:41 am

Mouse cursor not visible during test recording when overridi

Post by erikiknl » Wed Nov 01, 2017 10:28 am

My screen resolution is 3200x1800 so I have set scaling to 200%. When I start Ranorex Studio there are a few sizing issues (e.g. small buttons, partly visible banners), which are resolved when modifying RanorexStudio.exe properties => Compatibility tab => check "Override high DPI scaling behavior" and set "Scaling performed by" to "System". But when I start to record a test, the mouse cursor is invisible (the mouse does work as I can click things). Is there a solution for this?

OS: Windows 10 Enterprise
Ranorex version: 7.2.0+git.ffdcf8e6

User avatar
Vega
Posts: 109
Joined: Mon Jul 11, 2016 2:15 pm

Re: Mouse cursor not visible during test recording when overridi

Post by Vega » Thu Nov 02, 2017 10:10 pm

Are you working on multiple displays by chance? Please ensure the same DPI setting across all displays. Hopefully, this link will be helpful:
https://www.ranorex.com/help/latest/tec ... lingValues

It also may be worth trying the "application" setting for the DPI override:

Application - This forces the process to run in per-monitor DPI awareness mode. This setting was previously referred to as “Disable display scaling on high-DPI settings.”
This setting effectively tells Windows not to bitmap stretch UI from the exe in question when the DPI changes

Source:
https://blogs.windows.com/buildingapps/ ... rs-update/

f none of the above works, try reverting to a smaller scaling size and see if the cursor returns.

I hope this helps!

erikiknl
Posts: 2
Joined: Wed Nov 01, 2017 9:41 am

Re: Mouse cursor not visible during test recording when overridi

Post by erikiknl » Wed Nov 08, 2017 8:45 am

Vega wrote:Are you working on multiple displays by chance? Please ensure the same DPI setting across all displays. Hopefully, this link will be helpful:

It also may be worth trying the "application" setting for the DPI override:

Application - This forces the process to run in per-monitor DPI awareness mode. This setting was previously referred to as “Disable display scaling on high-DPI settings.”
This setting effectively tells Windows not to bitmap stretch UI from the exe in question when the DPI changes

Source:

f none of the above works, try reverting to a smaller scaling size and see if the cursor returns.

I hope this helps!
I'm working on a single display. The "application" setting has no effect, the scaling issues are the same as when no scaling override is selected (see attached screenshot).

Scaling settings:
{*] "Application": no effect
{*] "System": scaling looks OK but the mouse cursor disappears during recording
{*] "System (Enhanced)": scaling is worse, items that are too small are even smaller
Attachments
ranorex_scaling_issues.PNG
ranorex_scaling_issues.PNG (225.49 KiB) Viewed 340 times