Mouse moves to different point after recording

Ask general questions here.
CSPman
Posts: 13
Joined: Fri Dec 13, 2013 1:11 pm

Mouse moves to different point after recording

Post by CSPman » Fri Dec 13, 2013 1:41 pm

Hi Guys

I have just come to the end of an evaluation trial and will be purchasing a licnese shortly and have a small question.

When using recorder for a series of mouse left clicks to open some windows components the mouse on ocassions will move to a different point on the screen when the recording is run. This is an identical action that may be repeated a number of times so I have copied the action to see if this will fix it but it still goes to the wrong point. Any ideas why this should happen?

I am using the latest trial version on Win 2000 Server.

Regards...CSPman

Swisside
Posts: 92
Joined: Thu Oct 10, 2013 10:40 am

Re: Mouse moves to different point after recording

Post by Swisside » Mon Dec 16, 2013 10:32 am

Hello

Could you provide a snapshot ?

Or show me how you defined the path to the item.

Regards
A simple thank you always does wonders !

CSPman
Posts: 13
Joined: Fri Dec 13, 2013 1:11 pm

Re: Mouse moves to different point after recording

Post by CSPman » Mon Dec 16, 2013 10:46 am

Sorry...as it was during an "evaluation" period which has now run out I cannot re-run it again until my license comes through :cry:

Swisside
Posts: 92
Joined: Thu Oct 10, 2013 10:40 am

Re: Mouse moves to different point after recording

Post by Swisside » Mon Dec 16, 2013 11:14 am

Okay.

I hope you understand it's hard/impossible to help you without having more details :)

Feel free to ask once you get the licence !
A simple thank you always does wonders !

CSPman
Posts: 13
Joined: Fri Dec 13, 2013 1:11 pm

Re: Mouse moves to different point after recording

Post by CSPman » Thu May 01, 2014 3:53 pm

OK got a licence now and after further investigation I have found that it is a problem with the mouse position relative to the "containerhash". In my application when a item is placed into a window it defaults to that containerhash number and the mouse will move there and not where it was intended. However if I remove the container reference in the properties and set it to "no item" and give the mouse the relative position on the screen all is good.
So the next question is can I record just using the realtive screen positions (I get the same problem if I use Image Based recording)

My reference is Customer ID: RX715565

Regards...

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Mouse moves to different point after recording

Post by Support Team » Tue May 06, 2014 3:28 pm

Hello CSPman,

May I ask you to provide a Ranorex snapshot of your application to us? Either upload the file to the forum or send it to [email protected].

A detailed description on how to create a Ranorex snapshot can be found here.

Maybe you can point out which action on which element fails during the test execution?

Thank you in advance.

Regards,
Robert
.
Image