Need some help with website test

Ranorex Spy, Recorder, and Studio.
itzikp
Posts: 3
Joined: Tue Apr 30, 2013 11:37 am

Need some help with website test

Post by itzikp » Tue Apr 30, 2013 11:47 am

Hi

I'm trying to record a test of registration form in our web site but I want to record the test with the input ID's.

I start "ranorex studio" and went to "record", in the popup window I've entered at the middle section "Open a Browser" and entered the preferred URL ('https://www.casino.com/register/realreg.php") and chooses "Firefox" as the browser.

I fill in the fields and record the session

As soon as I finished the record I tested the session and it worked fine.

When I wanted to change the inputs from full path to input ID, the record stop working (the screen stocked on the page with out filled in anything).


Instead of:
container/container/element/container/element[4]/element/element[2]/element/element/element/element/element/table/row/cell/table/row[@accessiblename~'^1\.\ Tell\ us\ about\ yourself']/cell[1]/element[2]/table/row[@accessiblename='First Name:']/cell[2]/text[@accessiblerole='Text']

I entered:
/dom//input[#'firstname']
or
//input[#'firstname']
or
/form/*[@id='firstname']
or
/form/*[#'firstname']

nothing worke....

I would like to get some help with this issue...

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Need some help with website test

Post by Support Team » Thu May 02, 2013 8:23 am

Hello,

It seems that your browser is not instrumented correctly.
Please try to run the "Instrumentation Wizard" for the Firefox Browser.
Please let me know if you need any further information or assistance.

Regards,
Bernahrd
.
Image