.Net 4.0 and .Net 3.5, Capabilities Control/ControlNet11

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
DanielS
Posts: 29
Joined: Fri Apr 29, 2011 10:39 am

.Net 4.0 and .Net 3.5, Capabilities Control/ControlNet11

Post by DanielS » Fri May 13, 2011 12:19 pm

Hello,
I've got a urgent problem. I'm using Windows 7 and the newest Ranorex Studio.
With an installed .Net 4.0 framework (the same with .Net 4.0 extended), Ranorex recognizes all controls as ControlNet11. Creating a Ranorex.Control Objekt causes the exception "Capability Control not supported".
Additionally the paths consist of many "element"s instead of "containers" etc. .
Without .Net 4.0 ( with .Net 3.5? from Windows) it is like before, the controls are Ranorex.Control objects and the paths are containing "container"s and "element"s .
I've reinstalled .Net framework and Ranorex Studio a few times and nothing changed. The tested program is in .Net 3.5, but i must have .Net 4.0 installed. The testautomation uses many controls and i can't change them all to ControlNet11, because there are attributes in Ranorex.Control that i need that aren't in Ranorex.ControlNet11.
I don't get any limitation popups.
Here is a snapshot of the program with .Net 4.0:
snapshotNet40.rxsnp
Snapshot with .Net 4.0
(660.94 KiB) Downloaded 244 times
What can i do so that i can use .Net 4.0 AND the capability Ranorex.Control instead of Ranorex.ControlNet11 ??
Best regards,
Daniel

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: .Net 4.0 and .Net 3.5, Capabilities Control/ControlNet11

Post by Support Team » Fri May 13, 2011 12:32 pm

Hi,

Have you also Ranorex 2.x installed on this machine? If yes please uninstall it and repair the 3.x installation, because we have a bug which causes this behavior.

Regards,
Peter
Ranorex Team
.
Image

DanielS
Posts: 29
Joined: Fri Apr 29, 2011 10:39 am

Re: .Net 4.0 and .Net 3.5, Capabilities Control/ControlNet11

Post by DanielS » Fri May 13, 2011 1:27 pm

thank you very much, it worked!