.NET 4.0 throws an error in Ranorex trying to use linq

Bug reports.
Holger-Timm
Posts: 2
Joined: Mon Mar 25, 2013 3:34 pm

.NET 4.0 throws an error in Ranorex trying to use linq

Post by Holger-Timm » Mon Mar 25, 2013 4:39 pm

Hello,

i try to use linq to create a report for excel.
The problem is that .NET 4.0 is needed for this.

When i try to compile i get following errors:
1)
The reference assemblies for framework ".NETFramework,Version=v4.0" were not found. To resolve this, install the SDK or Targeting Pack for this framework version or retarget your application to a version of the framework for which you have the SDK or Targeting Pack installed. Note that assemblies will be resolved from the Global Assembly Cache (GAC) and will be used in place of reference assemblies. Therefore your assembly may not be correctly targeted for the framework you intend. (MSB3644)

2)
Parameter "SearchPaths" has invalid value "{CandidateAssemblyFiles}%3b
%3b
{HintPathFromItem}%3b
{TargetFrameworkDirectory}%3b
{Registry:Software\Microsoft\.NETFramework,v4.0,AssemblyFoldersEx}%3b
%3b
{GAC}%3b
{RawFileName}%3b
bin\Debug\Ranorex.Core.dll". Illegal characters in path. (MSB3248)

I tried to install Targeting Pack, reinstall targeting pack, update targeting pack, nothing work.
I also tried to install SDK, but this is impossible to install.

Do someone know how to fix he problem?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: .NET 4.0 throws an error in Ranorex trying to use linq

Post by Support Team » Tue Mar 26, 2013 12:19 pm

Hello,

Please try to install Windows SDK for Windows 7 and .NET Framework 4 again.
You could download it from Microsoft Download Center.

If you face any issues during installation of SDK please follow these steps:
Please uninstall Ranorex and Microsoft Visual C++ 2010 Redistributables.
Then, install SDK again and install Ranorex using setup.exe in order to install all prerequisites.

We recommend to update Ranorex to our current version 4.0.2.
Thank you.

Regards,
Markus (T)
.
Image