Newbie - Ranorex not seeing iOS app controls

Mobile Testing, Android App Testing.
RensterUK
Posts: 3
Joined: Fri Feb 18, 2011 1:21 pm

Newbie - Ranorex not seeing iOS app controls

Post by RensterUK » Fri Aug 30, 2013 3:42 pm

Hi All,

Just installed trial version of Ranorex Studio 4.1.0 and have successfully connected to the iPad 2 I have here.

When I create a new project, and try to record - I select "Mobile Recording", select the device, and our installed app.

First issue is "Could not launch app because no debug session....." - and the quoted ranorex help page (ranorex url /support/user-guide/20/ios-testing.html#NoDebugImage) isn't found. Not a big issue - can start the app myself of course. So I click "OK" and wait for recording to start. I then start our app under test - a hybrid app, that connects to a remote DB.

First thing our app does is present a native based login screen - 3 text fields (company, user, and pass). Enter all three, click login. All fine on the app.

Since I'm so new - I decide to see what Ranorex has captured and stop recording at this point. It has 1 action "Run Mobile App"... detailing our test app. NOTHING recorded for entering any login details etc.

I'll bet I'm doing something dumb so that my actions are not recorded... but ????!!!

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3945
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Newbie - Ranorex not seeing iOS app controls

Post by odklizec » Fri Aug 30, 2013 5:21 pm

Hi, are you sure your app is correctly instrumented? Just in case, try to record something with Ranorex RX browser...
http://www.ranorex.com/support/user-gui ... html#c4815
If the RXBrowser works and your app still don't then there is most probably something wrong with your app.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

RensterUK
Posts: 3
Joined: Fri Feb 18, 2011 1:21 pm

Re: Newbie - Ranorex not seeing iOS app controls

Post by RensterUK » Mon Sep 02, 2013 11:31 am

Ahhh I think that'll be the problem by the looks of it.

Now just to persuade the Devs and Managers that we need to put time to instrumentation etc... ;)

Thanks very much indeed!