No more screenshots in the report file upgrading from 7.2.1 to 9.2.1

Ask general questions here.
Jean-Louis GOUEZ
Posts: 7
Joined: Thu Oct 19, 2017 3:53 pm

No more screenshots in the report file upgrading from 7.2.1 to 9.2.1

Post by Jean-Louis GOUEZ » Fri Jan 24, 2020 4:20 pm

Hi,

We have just upgraded our Ranorex from version 7.2.1 to 9.2.1 with no major problem except that we don't get anymore screenshot in the report file when a recording is running properly.

However, that is a very bad news for us because, most of time, when something gets wrong it is linked with something that gets wrong at a previous step and we now get no screenshot of what happens on a successful step.

I have checked the options that setup the report tracing screenshots in the project properties with no success (I have changed the Tracing mode from Foreground to Background and changed the Quality parameter from Medium to High for example).
I also tried to programmatically change the properties of the TestReport object but without success.

Is there an option to get 9.2.1 reports runs like our old 7.2.1 ?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6036
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: No more screenshots in the report file upgrading from 7.2.1 to 9.2.1

Post by odklizec » Sun Jan 26, 2020 6:59 pm

Hi,

Upgrading from 7.x to 9.x is a big jump. There were a lot of changes introduced between these versions and some of them were breaking changes! Have you read release notes between 7.2.1 and 9.2.1? You should definitely read them before each upgrade.

My guess is that you are using a custom report template and you most probably did not update it with 9.x stylesheet? 9.x report template is very different from 7.x template. So if you are using custom report template, you must update it with 9.x stylesheet.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Jean-Louis GOUEZ
Posts: 7
Joined: Thu Oct 19, 2017 3:53 pm

Re: No more screenshots in the report file upgrading from 7.2.1 to 9.2.1

Post by Jean-Louis GOUEZ » Mon Jan 27, 2020 10:23 am

Thank you for your answer.

Obviously, I have read the release notes before migrating from 7.2 to 9.2 and the migration itself has been successful (more than 8H of automated tests runs now in 9.2 without any problem - about 100 functional test cases)
I also checked that both the RanorexReport.css and RanorexReport.xsl files are the new ones (The result is the same if I create a new solution from scratch)
The images are in the report only when a step crashes but not for the previous one (but most of time a step fails because something is wrong in a previous step but this previous step does not detect that it goes wrong).

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6036
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: No more screenshots in the report file upgrading from 7.2.1 to 9.2.1

Post by odklizec » Mon Jan 27, 2020 11:04 am

Hi,

I don't really remember a Ranorex version, which automatically created screenshots for passed steps? As far as I know, it always created screenshots only for failed steps?

There is a similar discussion regarding this topic...
https://www.ranorex.com/forum/viewtopic ... 74&p=53537
If you want a screenshot only for the last recording step, just add a Screenshot action at the end of every recording.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration