No Spy functionality at all

Bug reports.
houseofcutler
Posts: 52
Joined: Fri Mar 21, 2014 4:22 pm

No Spy functionality at all

Post by houseofcutler » Tue Oct 03, 2017 5:27 pm

Hi All,

I'm having trouble identifying a resolution to this problem and hoping you can help.

I set up a new laptop on Friday. i7 8GB Ram Windows 10 and installed the Latest Ranorex 7.2

Everythign has been working fine until today. After rebooting the laptop (possibly coinsidental) I am completly unable to open the Ranorex Spy.

I have tried using the spy and identification from the following:
I have reinstalled Ranorex, rebooted and disabled antivirus scannign etc. Nothing has made any difference to the issue. I am hoping maybe there is some known issue I was not able to find with my searches.

All ideas welcomed.

Thanks

Ben

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: No Spy functionality at all

Post by krstcs » Tue Oct 03, 2017 7:13 pm

Ben,

A few things to try:
1. Disabling scanning alone may not solve the issue with virus scanners, you should try completely disabling or uninstalling it (on-demand, background, firewall, etc. can all cause issues). What AV are you using? If you can't do it due to company restrictions, ask one of your network ops guys to do it for you and try it real quick. It that works, you know the issue and can chase it up the pole.
2. Have you tried running Ranorex Spy/Studio as admin? Does that help?
3. Close all other applications, including background apps. It might be necessary to disable some on-boot apps that might be causing issues.
4. Are you running any other DOM scanning apps or screen capture systems? These might conflict in certain situations.

I'm on Win 10 and have no issues, but I am only running Windows Defender (IMO it's better and lower-weight than any other AV program out there, but it helps that I'm friends with one of the designer/developers... :D ) and I'm a domain admin (small shop).
Shortcuts usually aren't...