Not able to start execution on Ranorex Agent 7.1.0

Ask general questions here.
Ajitpatil3011
Posts: 37
Joined: Thu Aug 22, 2019 4:14 pm

Not able to start execution on Ranorex Agent 7.1.0

Post by Ajitpatil3011 » Tue Jun 30, 2020 5:38 pm

I used to start execution on Ranorex agent 7.0.1 via my Ranorex Studio 9.2.X, but as I have updated my ranorex studio to 7.3.2 and agent to 7.1.0. Now I am not able to start execution on my ranorex agent. When I checked my Ranorex Agent logs, I found below error.

System.ArgumentException: Version string portion was too short or too long.
at System.Version.VersionResult.SetFailure(ParseFailureKind failure, String argument)
at System.Version.TryParseVersion(String version, VersionResult& result)
at System.Version.Parse(String input)
at Ranorex.Common.Types.OptCombinators.Map[T,TRes](Opt`1 self, Func`2 func)
at Ranorex.Dex.Components.TestExecution.Steps.ValidateRuntimeStep.Run(AbsoluteFilePath f, String arg)

Can Someone please help me to resolve this problem?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6036
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Not able to start execution on Ranorex Agent 7.1.0

Post by odklizec » Tue Jun 30, 2020 6:00 pm

Hi,

I somehow don’t understand what you are trying to achieve, but generally speaking, you should not mix Ranorex versions. Basically, if you are using Ranorex 9.2.x, you should use also appropriate agent version. Mixing 7.x and 9.x is a no go situation, no matter it worked in the past. It was just a pure luck 😁
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Ajitpatil3011
Posts: 37
Joined: Thu Aug 22, 2019 4:14 pm

Re: Not able to start execution on Ranorex Agent 7.1.0

Post by Ajitpatil3011 » Tue Jun 30, 2020 6:15 pm

Thanks Pavel :-)

I downgraded my Ranorex Studio version to 9.2.X, Now I am able to execute my scripts on Ranorex Agent 7.1.0.