Not found repository items

Ask general questions here.
ozzs
Posts: 4
Joined: Mon Nov 13, 2017 2:15 pm

Not found repository items

Post by ozzs » Wed Oct 10, 2018 8:02 am

Hi,

I have a solution on my PC which all tests work fine. I have no problem on my PC. However, when I run same solution on another PC, Ranorex can't find some of the repository items on the software even if these repository items exist on the solution. Therefore, I have to record again for the repository items can't find by Ranorex. I wondering that am I doing something wrong? I hope I could explain the problem that I'm facing with because I can't share Ranorex snapshot because of the our project restrictions.

We're using lastest Ranorex version in all PCs, problem was occurring in the older versions (since version 7) as well,
OS: Windows 7,
Hardware: i7, 16GB Memory, onboard gpu card (some of other PCs has higher configurations).

Regards,
Ozmert

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3955
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Not found repository items

Post by odklizec » Wed Oct 10, 2018 8:17 am

Hi,

Problem like this could be caused by different version of OS, different version of .net or runtime libs, eventually different version of GUI library used by the AUT. Unfortunately, because you can't share snapshots, there is not much anyone here (including support) can do or suggest. Could you, at very least, show us the xpaths for individual problematic elements, as they were recorded on different systems?

Generally speaking, if you are testing your app on different systems (e.g. Win 7 and Win 10), you must be prepared that some GUI controls may look differently and also their xpaths could be more or less different. Therefore, you must debug your test on both (all different) systems and find the common xpaths, which will work on all systems. There is no way around.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration