Not recognizing Flex ItemRenderer elements in DataGrid

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
robert_butler
Posts: 24
Joined: Tue Apr 03, 2012 3:05 pm

Not recognizing Flex ItemRenderer elements in DataGrid

Post by robert_butler » Tue Apr 10, 2012 3:24 pm

Spy is not recognizing Flex ItemRenderer produced elements in DataGrid. I am only getting the data row. I am using Ranorex 3.2.2.

Follow up information: I need to click on an icon image within a column (it has it's own column) within the data row.

If Ranorex can not determine/see the elements, can I determine the click location based on a percentage of the data row length? Or by using image comparison to find the icon to click?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by Support Team » Wed Apr 11, 2012 12:51 pm

Hi,

Please update to the actual 3.2.3, you will find the link to the newest version on the start page of Ranorex Studio.
Can you also send us a Ranorex Snapshot file of the specific DataGrid?
Following link will show you how to generate a snapshot file:
http://www.ranorex.com/support/user-gui ... files.html
If Ranorex can not determine/see the elements, can I determine the click location based on a percentage of the data row length? Or by using image comparison to find the icon to click?
You can make a location or an image based click, the Click method is overloaded so you can add a location as parameter, for additional information about the method please take a look at our .Net API, RxStuio->Help->.Net Api Documentation.
If you want to make a image based click you can for instance enable the image based recording checkbox during the recording or you can also use the Spy tool and UserCode to perform an image based click, therefore take a look at the following links:
http://www.ranorex.com/support/user-gui ... x-spy.html
http://www.ranorex.com/support/user-gui ... html#c3326

Regards,
Markus
Ranorex Support Team
.
Image

robert_butler
Posts: 24
Joined: Tue Apr 03, 2012 3:05 pm

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by robert_butler » Wed Apr 11, 2012 3:41 pm

Hi,

It still does not recognize the individual elements within the data grid row with 3.2.3. I will get you a snapshot.

I do not want to use location (on screen) because of possible screen resolution differences. It was recorded with a location, but when I was running on a different resolution, it was not finding the element. I can't remove the location, because it does not recognize an individual element within the data row.

What am I left with? Image recognition? What happens if I want to click on something within a data row that doesn't have an icon?

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by Support Team » Thu Apr 12, 2012 1:30 pm

Hi,

Thanks for the snapshot!
Normally such a table should be recognized well, but it seems that something went wrong, maybe an Error/Exception was thrown, therefore we would need the log file of the preloader.
You will find the file at the following location "C:\Users\username\AppData\Roaming\Macromedia\Flash Player\Logs".

Thanks in advance!

Regards,
Markus
Ranorex Support Team
.
Image

robert_butler
Posts: 24
Joined: Tue Apr 03, 2012 3:05 pm

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by robert_butler » Thu Apr 12, 2012 2:40 pm

Hi,

I am not seeing an error in the application. I do not have a Logs folder in that Flash Player directory.

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by Support Team » Mon Apr 16, 2012 3:47 pm

Hi
robert_butler wrote:I am not seeing an error in the application. I do not have a Logs folder in that Flash Player directory.
Which type of instrumentation do you use to automate your flex application? Are you using the preloader or the module method or the automation lib method?

Would it be possible to post us a Ranorex Snapshot of your Flex application?
How to create a Snapshot

Regards,
Peter
Ranorex Team
.
Image

robert_butler
Posts: 24
Joined: Tue Apr 03, 2012 3:05 pm

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by robert_butler » Tue Apr 17, 2012 3:04 pm

I sent the snapshot last week, just resent it.

I am using Ranorex preloader.

Thanks,
Bob

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by Support Team » Wed Apr 18, 2012 10:56 am

Hi,

Thank you for the snapshot. Without the logfile we cannot narrow down the issue. Did you enable the tracing option when you've instrumented the preloader? If this tracing flag isn't set, Ranorex doesn't generate any log files. Please could you check this and then send us the logfile?

Regards,
Peter
Ranorex Team
.
Image

robert_butler
Posts: 24
Joined: Tue Apr 03, 2012 3:05 pm

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by robert_butler » Wed Apr 18, 2012 3:12 pm

log file sent

thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by Support Team » Wed Apr 18, 2012 3:26 pm

Hi,

Did you track the element before you sent use the log file?

Regards,
Peter
Ranorex Team
.
Image

robert_butler
Posts: 24
Joined: Tue Apr 03, 2012 3:05 pm

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by robert_butler » Wed Apr 18, 2012 3:39 pm

I believe I tracked the element in the original log file sent, but I just sent a new one just in case.

Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Not recognizing Flex ItemRenderer elements in DataGrid

Post by Support Team » Thu Apr 19, 2012 9:04 am

Hi,

Thank you for the logfile again. We didn't found any strange logging in there. To reproduce the issue, would it be possible to send us a sample including your datagrid or is it possible to get access to your application?

Regards,
Peter
Ranorex Team
.
Image