not seeing pages in Chrome

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
JayInMA
Posts: 10
Joined: Thu Jan 10, 2013 5:10 pm

not seeing pages in Chrome

Post by JayInMA » Mon Jun 02, 2014 6:03 pm

using the spy I do a simple path

I open our web app in Chrome then in code call this:

IList<WebDocuments> docs= Host.Local.Find("/dom");

Sometimes I will see my chrome /dom pages some items I don't (for same page)

often I am able to use RX to access controls to log in, but the resultant page, sometimes RX sees it other times it does not. Works fine in IE , have not checked Firefox yet

Any pointers?

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: not seeing pages in Chrome

Post by krstcs » Mon Jun 02, 2014 7:01 pm

First, could you please answer the following questions when posting with problems as it will allow us to understand the problem better:

1. What version of Ranorex are you using?
2. What OS are you running on?
3. What platform is the application built on (HTML/Java/.NET/Win32/Flash/Flex, etc.)?
3. What browser and version (for web apps)?
4. What mobile OS and version (for mobile apps)?

And finally, post a snapshot of the app in question (if able) and a sample script that demonstrates the problem.



My guess would be that the Chrome extension for Ranorex is not installed/working correctly.

Have you made sure that the extension is installed in Chrome and that it is working?

If you are using Chrome 33 or higher, are you getting a popup from Chrome about the Ranorex extension not being in the app store? If so, you must CANCEL it (do not click DISABLE).

If all of those fail, have you tried uninstalling, rebooting and then re-installing Ranorex?
Shortcuts usually aren't...