Object cannot be found

Ranorex Spy, Recorder, and Studio.
ranisti
Posts: 5
Joined: Mon Sep 24, 2012 5:02 pm

Object cannot be found

Post by ranisti » Mon Sep 24, 2012 6:01 pm

Hi,

I have made a short test which has worked.

After some minutes the same test has not worked:

"No element found for path 'element' within 30s.
The folder 'MesapExplorerRepository.M4Explorer.Element4823442161' was not found.
Failed to find item 'MesapExplorerRepository.M4Explorer.Element4823442161.Element01'.
Show/Hide Stacktrace"

I have jumped to the object and I have tried to track it once again... I have however received an error.

My questions:

- what is the reason that a test runs successfully but after 5 Min. it crashes?
- if one object is not found how can RX identify it?

Can I attach it again to repository?

Thank you for your help.

Kind regards

I.
Attachments
error.PNG
error.PNG (22.79 KiB) Viewed 808 times
Deskripoter_nach_tracken.PNG
Deskripoter_nach_tracken.PNG (70.24 KiB) Viewed 808 times
Deskripoter_hinfuegen.PNG
Deskripoter_hinfuegen.PNG (113.96 KiB) Viewed 808 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Object cannot be found

Post by Support Team » Fri Oct 05, 2012 4:08 pm

Hello,

In your second screenshot Ranorex finds two elements with the index 2, so Ranorex cannot decide which element you want to find.
Which version of Ranorex do you use?
Which technology is used in your application (e.g. WinForms, WPF, etc.)?
Can you please explain a little bit more detailed what you are doing to get the error?

Regards,
Bernhard
Ranorex Support Team
.
Image

A.Gergely
Posts: 2
Joined: Tue Sep 25, 2012 8:55 am
Location: Hungary

Re: Object cannot be found

Post by A.Gergely » Fri Oct 05, 2012 4:39 pm

Hello,

It can be a problem with an earlier Ranorex version. Try it out with the latest version.
Try to find the element with other detail, not with the Index number, with that RX can decide which element You want to found.

Regards,
Gergely