Object found by Spy but not at runtime

Bug reports.
dochoa
Posts: 29
Joined: Tue Jul 16, 2013 11:36 pm

Object found by Spy but not at runtime

Post by dochoa » Tue Mar 07, 2017 12:16 am

Hello,

I have this xpath:
.//div[#'awe-listContainer']/div/div[@class!='flex-content light-azure-bg']/div/select[@data-bind='value: languageCode, event: {blur: validateItem, change: updateItem}' and @value=$LanguageCode]

Using Spy or from the Ranorex Repository browser I can find and highlight the object.
If I run the test module with the object by itself, the object is found and it is successful.

But every time I run my entire test suite, it cannot find the object. Same computer, same browser that I used to highlight the object in spy.

How can this happen? What is different at runtime?

OS: Windows 7 SP1
Browser: Chrome 56.0.2924.87
Ranorex: 6.0.1

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3914
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Object found by Spy but not at runtime

Post by odklizec » Tue Mar 07, 2017 8:23 am

Hi,

At first, Ranorex 6.0.1 is way too old and no longer supported. Please update it with most recent 6.2.1.

At next, please upload a Ranorex snapshot (not screenshot) of the problematic element along with exact error you are getting (ideally Ranorex report). Without snapshot and error message, it's impossible to tell what's wrong.

The most common reason why the xpath is not found while running entire test suite is not binded/incorrectly binded variable(s). Are you sure the variable $LanguageCode is binded to a correct data source?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration