Object identification for visual comparison

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Yuki
Posts: 2
Joined: Fri Oct 17, 2014 2:52 pm

Object identification for visual comparison

Post by Yuki » Fri Oct 24, 2014 10:38 am

Hi,

I am having a trouble identifying the web object using Ranorex trial version (I am a beginner of Ranorex).

The test step is simple:
1) Open Browser
2) Wait for the the page is present
3) Validate: ContainImage in the specified location

I created this step using the "Record and play" function.

When I rerun this test, this fails by validating the image which I didn't specify (Ranorex application itself) and/or capturing the whole screen not the specified location.

If someone could advise me where I can find the cause of this issue,and how I can fix this, it would be much appreciated.

Kind regards,
Yuki
Attachments
RanorexErrorReport.png
Error report
RanorexErrorReport.png (109.98 KiB) Viewed 763 times

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Object identification for visual comparison

Post by krstcs » Fri Oct 24, 2014 1:27 pm

Are you using a multi-monitor setup?

When Ranorex cannot find the element it seems to default to taking a screenshot of the 1st monitor's desktop.



The real issue here is, why did Ranorex not find the element? :D

I would suggest that you open up your application under test (AUT) and Ranorex Spy and use Spy to track the AUT. That will show you the actual structure of the AUT and maybe you can check that against your XPath for the repository item and find the problem.

If you post a snapshot of your AUT and the path you are using, we might be able to help a bit. See this page for information on creating a Ranorex Snapshot.


Edit to add: By the way, WELCOME to Ranorex!
Shortcuts usually aren't...