Object Not Found when Test is Ran by Jenkins

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
haider
Posts: 13
Joined: Mon Oct 08, 2018 2:15 pm

Object Not Found when Test is Ran by Jenkins

Post by haider » Sat Jun 22, 2019 3:41 pm

Hi,

I've a problem with one of my tests who try to find a navigationTreeList in our software and then get all the Items in a list.
Once all items are in the list, I try to go through the list to find the item I'm looking for and then click on.

So this test wroks fine when it's ran from ranorex study on an agent.
It also works fine when I run it from Ranorex Studio on my programming computer.
But when this test is Ran by Jenkins on the same agent above it fails because it couldn't find an item which match the item I'm looking for (DemoUnit).

So I ran Ranorex Studio on the agent then I did highlight (works perfectly) I tried to check the RxPath so I spied on the object (their is no difference).

Here is the RxPath

Code: Select all

/form[@controlname='Software']/container[@controlname='mpContextualHelpContainer']/?/?/container[@controlname='panel1']/container[@controlname='mpMainPanel']/?/?/container[@controlname='mpSplitContainer']/container[@controlname='panel1']/container[@controlname='CollapsingControl']//container[@controlname='mpCurrentPagePanel']//container[@controlname='TreeViewControl']/element[@controlname='mpTreeViewAdv']
Here is the navigationTree
Image

Here how I get the NavigationTree
Image

Here how I get all Items in the NavigationTree
Image

Here how I try to find if it match the Item I'm looking for
Image


NB : My code works fine (at least form me :D )
Thank you for your help

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4918
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Object Not Found when Test is Ran by Jenkins

Post by odklizec » Mon Jun 24, 2019 8:11 am

Hi,

At first, could you please post a Ranorex snapshot of the problematic element/available parent element or entire app? Ideally, take the snapshot manually and also via recording module (via test started from Jenkins). Comparing both snapshots could help with identification of the issue. Also, you forgot the mention your actual Ranorex version? If you are using anything older than 9.1, please update it and repeat the test. Thanks.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

haider
Posts: 13
Joined: Mon Oct 08, 2018 2:15 pm

Re: Object Not Found when Test is Ran by Jenkins

Post by haider » Tue Jun 25, 2019 5:02 pm

Hi odklizec,

Thank you for helping me.
My actual version is 9.0.0

I update Ranorex to version 9.1
Now I'm facing a new issue which's

Code: Select all

Could not found file or Assembly 'Ranorex.Core.Resolver', Version 9.1.0.0
Do you have any knowledge about this problem?
I found that other users faced this problem but with older versions.

Thank you

qwertzu
Posts: 247
Joined: Wed Jan 25, 2017 11:08 am

Re: Object Not Found when Test is Ran by Jenkins

Post by qwertzu » Thu Jun 27, 2019 1:06 pm

hi

First try to clean and rebuild your solution. (Build -> Clean Solution; Build -> Rebuild Solution)
If that does not help, you could try a clean re-installation of Ranorex with exactly these steps:

1. Uninstall Ranorex
2. Restart your machine
3. Install Ranorex 9.1 via the *.exe file

regards, qwertzu

haider
Posts: 13
Joined: Mon Oct 08, 2018 2:15 pm

Re: Object Not Found when Test is Ran by Jenkins

Post by haider » Thu Jul 04, 2019 6:03 pm

I still have difficulties to find that object.
Please find in attachement the Snapshot. (Ranorex version 9.1.0)

Concerning my rpoblem with the dll Resolover.Core i found the solution:

Framework .Net 4.6.2 was the issue.
What you have to do is to install it again.

Anyway thank you guys for your help :P
Attachments
SnapNavigationTreeList.rxsnp
(1.09 MiB) Not downloaded yet