Object recognition failure

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Tnimni
Posts: 49
Joined: Thu Jan 02, 2014 4:03 pm

Object recognition failure

Post by Tnimni » Mon Feb 03, 2014 2:04 pm

Hi,

I have developed Automation tests for a client, that client purchased Ranorex license and wish to run the tests on his Own machines.

the development was done on my machine and works perfectly, after copying the code to client machine and running it several times, it appears the code is not stable on his machine

some Test Objects are not recognized on his machine which is weird.

I noticed that his machine is VERY slow, and some actions takes a lot of time, so i added a method to the test which run in a loop until (process.responding == true).

what could be the reason for missing objects on different machines?

Regards,

Tsachi

User avatar
mebner
Posts: 61
Joined: Tue Dec 17, 2013 6:42 pm

Re: Object recognition failure

Post by mebner » Tue Feb 04, 2014 1:30 pm

Hi,

There could be several reasons, but they mostly depend on the technology which is used by the application under test.
So which technology is used?
What type of failures do you get?
Have you already tried to increase the search timeouts for your repository items?
Which Ranorex version is in use?

Please also check if all prerequisites were installed on the customer's machine. You find the list of the prerequisites here: System Requirements.
Another page were you find different points for troubleshooting is the following one: General Troubleshooting.

Regards,
Markus

Tnimni
Posts: 49
Joined: Thu Jan 02, 2014 4:03 pm

Re: Object recognition failure

Post by Tnimni » Tue Feb 04, 2014 2:16 pm

Hi,

1. The tech being used is .net WinForms with DevExpress controls.
2. The failures are usually object not identified
3. The time out is set for 30000 ms.
4. Ranorex Studio being used is 4.1.2.16100 and .NET Runtime Version 4.0.30319.1008

Prerequisites are all in place, i have tried to uncheck "Use asynchronous dispatching of mouse and keyboard events" + since the remote computer on which i'm running that automation is very slow which causes the AUT to **not respond** at times, i added a method which waits until it is responsive again.

Kind regards,

Tsachi

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Object recognition failure

Post by Support Team » Thu Feb 06, 2014 2:32 pm

Hi Tsachi,

Since it is a WinForms application please also check if the extended version of the .Net 4.0 framework is also installed on the specific machine as described here: .NET WinForms .
If it is not installed please install it and then it is also needed to install Ranorex again.

Regards,
Markus
.
Image

Tnimni
Posts: 49
Joined: Thu Jan 02, 2014 4:03 pm

Re: Object recognition failure

Post by Tnimni » Thu Feb 06, 2014 3:18 pm

Hi,

.net 4.0 extended is installed, how ever Ranorex was installed before it was installed,

if i "upgrade" Ranorex to 4.1.5 on that site is it enough, or do i have to uninstall and reinstall it?

Regards,

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Object recognition failure

Post by Support Team » Thu Feb 06, 2014 4:07 pm

Hi,

To be sure that the new dlls get installed correctly it is safer to uninstall Ranorex, restart the machine and then install the new version of Ranorex.

Regards,
Markus
.
Image