Object SearchTimeout

Ask general questions here.
jainaakash
Posts: 48
Joined: Thu Jun 10, 2010 12:06 pm

Object SearchTimeout

Post by jainaakash » Wed Nov 03, 2010 10:17 am

Hi Team,

I am facing a typical problem with search timeout. I have an application form (root folder in repository). I look for the form if that exsists and proceed. It used to wait for the default time or searchtimeout (if specified) and then proceed further. But lately, at few ocassions it seems to wait for the form indefinitely.

I am not able to figure out what could be the reason for this inconsistency. Please help.

Repository items:
ItemName - Application_Error (This is the application root folder)
Path - /form[@title='Application Error']

Code
==============
Recording1.repo.Application_Error.SearchTimeout = msSearchTimeout
If Recording1.repo.Application_Error.SelfInfo.Exists Then
==============

The test run gets stuck and the tool seems to be waiting indefinitely for the 'Application_Error' form.

Thanks and Regards,
Aakash

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Object SearchTimeout

Post by Support Team » Wed Nov 03, 2010 3:03 pm

hi,

we've tried to reproduce the problem but we weren't able to do so.
So can you please send us a sample application, or rather the source code of the application where the problem occurs to [email protected].
This will make it much easier to solve the issue.

Regards,
Tobias
Ranorex Team
.
Image

User avatar
sdaly
Posts: 238
Joined: Mon May 10, 2010 11:04 am
Location: Dundee, Scotland

Re: Object SearchTimeout

Post by sdaly » Wed Nov 03, 2010 3:18 pm

I think I have experienced this same issue before too. We use PrimoPDF when printing and we use to use tryfindsingle to check for the PrimoPDF form which pops up. Occasionally Ranorex would simply hang at the line before the tryfindsingle. We eventually just used a try catch to determine the forms attendance and put a static delay beforehand which seems to work ok. We have no idea why it does so and could not pinpoint the issue.....

User avatar
artur_gadomski
Posts: 207
Joined: Mon Jul 19, 2010 6:55 am
Location: Copenhagen, Denmark
Contact:

Re: Object SearchTimeout

Post by artur_gadomski » Thu Nov 04, 2010 8:41 am

I think I had the same issue:
http://www.ranorex.com/forum/ranorex-ha ... t1551.html

It seemed to resolve itself for me. Last post I've made says:
I have changed a couple of things since hanging:
Moved to VisualStudio 2008.
Upgraded to Ranorex 2.3.3
Changed target .Net Framework from 1.0 to 3.5

I haven's seen hanging problems since.

User avatar
sdaly
Posts: 238
Joined: Mon May 10, 2010 11:04 am
Location: Dundee, Scotland

Re: Object SearchTimeout

Post by sdaly » Thu Nov 04, 2010 4:12 pm

Thanks artur, we have changed to 3.5 and have not seen the issue since:) Hopefully I have not spoken too soon!