Objects invalid inside table

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
n1kemax
Posts: 8
Joined: Wed Mar 06, 2019 1:55 pm

Objects invalid inside table

Post by n1kemax » Wed Mar 06, 2019 2:37 pm

Hi Team,

We have desktop application. And I have a problem with recognizing objects in table after I change something in it.

I will attach screenshots (I can't attach a snapshot for reasons security policy)

Before changes :
before_changes.JPG
before_changes.JPG (16.34 KiB) Viewed 203 times
After changes :
after_changes.JPG
after_changes.JPG (16.4 KiB) Viewed 203 times
We use :
Win 10 x64
Ranorex 8.3.3

Any help would be greatly appreciated :D
Attachments
before_changes.JPG
before_changes.JPG (16.34 KiB) Viewed 199 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5068
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Objects invalid inside table

Post by odklizec » Thu Mar 07, 2019 9:02 am

Hi,

Unfortunately, without seeing the app under test, there is not much anyone here can do or suggest. I would suggest you to contact directly Ranorex support and request a remote session with them, so they can examine the problem in a realtime and eventually suggest a solution. Check also this post:
viewtopic.php?f=15&t=13310&p=52404#p52373
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration