Objects not recognized properly

Ask general questions here.
von
Posts: 2
Joined: Mon Aug 13, 2012 7:25 pm

Objects not recognized properly

Post by von » Mon Aug 13, 2012 7:39 pm

I am looking at Ranorex as a potential functional testing tool for Epic application.
I run Epic fat client on my Macbook laptop in Parallel environment.
Epic is a windows-based application with embedded web-browser-capable frames. Epic is used extensively in healthcare industry.

I recorded and reran the test, the test always stop because objects were not able to be identified. When I tried to identified the objects, Spy always gave me the same result. (please look at the attached PNG file).

Can anyone tell me what I do wrong here?

Thanks,
Nghi Vo
Attachments
Screen Shot 2012-08-13 at 2.31.08 PM.png
Screen Shot 2012-08-13 at 2.31.08 PM.png (450.38 KiB) Viewed 723 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Objects not recognized properly

Post by Support Team » Tue Aug 14, 2012 12:42 pm

Hi,

In order to analyze the issue we would need a Ranorex Snapshot file of the element which couldn't be found, the rxlog file and the RxPath which is used in your solution for that element.
If you like you can send the files to our support mail address, [email protected].
Maybe one of the used attributes change when the application under test is restarted, if so you just have to use another unique one.
Here are some useful links about the RxPath:
RanoreXPath Editor
RanoreXPath

Regards,
Markus
Ranorex Support Team
.
Image

von
Posts: 2
Joined: Mon Aug 13, 2012 7:25 pm

Re: Objects not recognized properly

Post by von » Tue Aug 14, 2012 4:21 pm

I used Spy to track the item in question, its XPath is:

/dom[@caption='TreeControl']//a[#'LINKKEY193512012MR_NODE_HISTORY_SPECIALTY_PEDS']

The issue here is the portion of the link value is dynamically generated. In this case it is 193512012.

How can I handle this?
Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Objects not recognized properly

Post by Support Team » Thu Aug 16, 2012 9:42 am

Hello,

You can use RanoreXPath with regular expression.
E.g. you can use the following regular expression to recognize the element regardless of the dynamically generated number:

[@id~'LINKKEY.*.MR_NODE_HISTORY_SPECIALTY_PEDS']

Regards,
Bernhard
Ranorex Support Team
.
Image