OpenBrowser issue with Win 10\IE 11

Bug reports.
fwason
Posts: 26
Joined: Wed Aug 24, 2011 10:39 pm

OpenBrowser issue with Win 10\IE 11

Post by fwason » Thu Apr 20, 2017 8:38 pm

var browserProcessId = Host.Local.OpenBrowser(crmUrl,
Configuration.GetConfigurationValue("BrowserType"), true, true);

isn't working on Windows 10, testing IE 11. The parameter TRUE for 'close existing' is causing an access denied message to be thrown. if I use the following then it is OK, but I need to close similar browsers in another way.
browserProcessId = Host.Local.OpenBrowser(crmUrl,
Configuration.GetConfigurationValue("BrowserType"));

Right now I'm catching the error, using the method without the close and maximize parameters, and closing browsers which might be open already by scanning for open web browsers and calling Close() in the WebDocument class.

McTurtle
Posts: 191
Joined: Thu Feb 23, 2017 10:37 am
Location: Benedikt, Slovenia

Re: OpenBrowser issue with Win 10\IE 11

Post by McTurtle » Fri Apr 21, 2017 1:45 pm

Hello fwason,

What is "Configuration.GetConfigurationValue("BrowserType")" and where is this from?

If I put just "IE" instead of this, it works for me. Closes IE if it is already open without issues. I have full admin rights and Enhanced Protected Mode disabled in IE.

Do you have Enhanced Protected Mode disabled and do you have admin rights?
Also, please let me know if writing "IE" instead of Configuration.GetConfigurationValue("BrowserType") has any influence.

Regards,
McTurtle

fwason
Posts: 26
Joined: Wed Aug 24, 2011 10:39 pm

Re: OpenBrowser issue with Win 10\IE 11

Post by fwason » Fri Apr 21, 2017 2:36 pm

no, it doesn't work with IE. The property accessor you're referring to is part of our framework... reading the type of browser under test for a specific run\configuration.

I have full admin rights, EPM disabled. This is only happening on a Win 10 machine... Win 7 and Win 8.1 are fine. As I mentioned, this works (abridged code presented):

IList<Ranorex.WebDocument> AllDoms = Host.Local.FindChildren<WebDocument>();
foreach (WebDocument myDom in AllDoms)
if (myDom.Domain == domain) //here domain is the application domain under test. We don't care to close unrelated windows
:
:
myDom.Close();

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: OpenBrowser issue with Win 10\IE 11

Post by krstcs » Fri Apr 21, 2017 4:27 pm

Please ALWAYS include the FULL Ranorex version when raising issues.

*** DELETED INCORRECT INFORMATION ***

Have you tried a clean reinstall of Ranorex?

1. Uninstall Ranorex.
2. Reboot the system.
3. Reinstall using the Ranorex-6.2.1.exe download (not the MSI).
Last edited by krstcs on Tue Apr 25, 2017 2:40 pm, edited 1 time in total.
Shortcuts usually aren't...

fwason
Posts: 26
Joined: Wed Aug 24, 2011 10:39 pm

Re: OpenBrowser issue with Win 10\IE 11

Post by fwason » Mon Apr 24, 2017 4:29 pm

I'm deleting this reply as Ranorex has reached out directly to work on the issue together. I will post an update when appropriate.
Last edited by fwason on Wed Apr 26, 2017 1:58 pm, edited 2 times in total.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: OpenBrowser issue with Win 10\IE 11

Post by krstcs » Mon Apr 24, 2017 10:03 pm

First, I'm trying to help. Regardless of whether you like or agree with my answers or not, my intention is to help. I'm sorry if you feel any of this is not helping.

*** DELETED DUE TO INCORRECT INFORMATION ***

Finally, the information I referenced should be posted in the plain text of the post, every time you raise an issue, regardless of whether it is included in attached files, because it is easier for those helping to see it, and sometimes attachments don't work on other's systems. This is stated in the Please Read posts that are stickied at the top of the forums.
Last edited by krstcs on Tue Apr 25, 2017 2:38 pm, edited 1 time in total.
Shortcuts usually aren't...

fwason
Posts: 26
Joined: Wed Aug 24, 2011 10:39 pm

Re: OpenBrowser issue with Win 10\IE 11

Post by fwason » Tue Apr 25, 2017 2:01 pm

.....
Last edited by fwason on Wed Apr 26, 2017 1:59 pm, edited 1 time in total.

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: OpenBrowser issue with Win 10\IE 11

Post by krstcs » Tue Apr 25, 2017 2:37 pm

I must apologize. You are correct, I was looking at the IHost interface instead of the Host class.

Again, I apologize if anything I've said has caused problems. I'll delete my original post to clear up the confusion.
Shortcuts usually aren't...