Performance issues with nested root folders in repo

Ranorex Spy, Recorder, and Studio.
mrrioes
Posts: 6
Joined: Wed Oct 10, 2012 8:56 am

Performance issues with nested root folders in repo

Post by mrrioes » Wed Oct 10, 2012 11:46 am

Hi all,

I have massive performance issues when I create nested root folders in my item repository.
I expected there should be no differance if I add an element right under the DOM or create a neasted root folder structure... Look at the attached image:

Image

If I run my test case with the first configuratoin ranorex find the elements immediately. With the second configuration ranorex doesnt't find the elements within 3 minutes(then ranorex crashes - at least for the element "prototype request"... when I drop "PPAS" into the "dotNetElements" folder it takes quite some time but the element will be found after ~40s).
As a "workaround" I just use "normal" folder... but it would be nice to use root folders so any ideas how to fix the performance issues?

Greets

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Performance issues with nested root folders in repo

Post by Support Team » Thu Oct 11, 2012 3:45 pm

Hello,

Unfortunately I cannot reproduce this issue.
Which version of Ranorex do you use?

Regards,
Bernhard
Ranorex Support Team
.
Image

mrrioes
Posts: 6
Joined: Wed Oct 10, 2012 8:56 am

Re: Performance issues with nested root folders in repo

Post by mrrioes » Fri Oct 12, 2012 7:20 am

Hi,

I use Ranorex version 3.3.2.19144.

Greets

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Performance issues with nested root folders in repo

Post by Support Team » Fri Oct 12, 2012 9:45 am

Hello,

Could you please check if the 'Use Cache' property of the rooted folder is set to false. It could be that the caching information of the folder is incorrect.

Regards,
Bernhard
Ranorex Support Team
.
Image

mrrioes
Posts: 6
Joined: Wed Oct 10, 2012 8:56 am

Re: Performance issues with nested root folders in repo

Post by mrrioes » Fri Oct 12, 2012 10:33 am

Hi,

nope this property is set to true.

Regards

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Performance issues with nested root folders in repo

Post by Support Team » Fri Oct 12, 2012 1:26 pm

Hello,

Please set the property to false and check if the if the performance improves.

Ragards,
Bernhard
Ranorex Support Team
.
Image