Perpetual search if the application under test does not work

Bug reports.
usov
Posts: 19
Joined: Mon Dec 04, 2017 11:13 am

Perpetual search if the application under test does not work

Post by usov » Thu Apr 04, 2019 11:48 am

Sometimes my test application stops responding.
And if at this moment is executed WaitForExists(1000) , then there is an eternal search (you can search for hours)
Unfortunately, I can not attach a snapshot, but I am sure that the error in the method WaitForExists() and non-working application

Windows 7 x64
Ranorex 9.0.0

McTurtle
Posts: 227
Joined: Thu Feb 23, 2017 10:37 am
Location: Benedikt, Slovenia

Re: Perpetual search if the application under test does not work

Post by McTurtle » Thu Apr 04, 2019 11:59 am

Hi usov,

If your application stops responding, then the Ranorex injection can also hang and this causes the eternal wait. You will have to solve this in a different way. Does the freeze of your application normally happen at the same spot at the same time? You could maybe have a hard wait just before that and then check the Process.Responding property. If it is not responding, then fail the test. Can you try that?

Regards,
McTurtle

usov
Posts: 19
Joined: Mon Dec 04, 2017 11:13 am

Re: Perpetual search if the application under test does not work

Post by usov » Thu Apr 04, 2019 3:06 pm

Hi,McTurtle!
Thanks for the advice, it helped!
And what will need vyzat to test rolled up and not performed teardown ?

McTurtle
Posts: 227
Joined: Thu Feb 23, 2017 10:37 am
Location: Benedikt, Slovenia

Re: Perpetual search if the application under test does not work

Post by McTurtle » Fri Apr 05, 2019 6:42 am

Hello Usov,

To prevent the modules in teardown from being ran, use this code: Complete stop on fail/error

Regards,
McTurtle