Play Button in Studio Recorded Module don't work

Ranorex Spy, Recorder, and Studio.
binonline
Posts: 12
Joined: Thu Apr 19, 2012 4:12 pm

Play Button in Studio Recorded Module don't work

Post by binonline » Thu Apr 19, 2012 4:50 pm

I use the recorded modules and have some actions prepared which run successfully via the RUN button on TestSuite level. But I would like to run just this recorded module via the PLAY.
If I press the PLAY button, build is successful, loading of the modules is starting then I get: Navigation to webpage was cancelled on the rxlog tab and in the background a file download msg is pending (all attached).
Unfortunately I unchecked the 'Always ask before opening' so I get tons of new windows opened now.
How to resolve :?:

PS: Sorry, I should have posted it under the bug reports
Attachments
Play Result2.JPG
Download window in the background
Play Result2.JPG (32.77 KiB) Viewed 1287 times
Play Result.JPG
Result on Studio
Play Result.JPG (27.62 KiB) Viewed 1287 times
Play Button.JPG
Button pressed
Play Button.JPG (27.9 KiB) Viewed 1287 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Play Button in Studio Recorded Module don't work

Post by Support Team » Fri Apr 20, 2012 2:54 pm

Hi,

Can you upload or send us the specific report file?
You can upload it here or you can send it to [email protected].
You can also open the rxlog file with a text editor to check if one of the plugins couldn't be loaded, if there is a message similar to this one “Failed to load default plugins. Please reinstall Ranorex. Cannot load required flavor 'win32' from any of the plugins.”, you have to reinstall Ranorex, because it seems that the installation is broken.

Regards,
Markus
Ranorex Support Team
.
Image

binonline
Posts: 12
Joined: Thu Apr 19, 2012 4:12 pm

Re: Play Button in Studio Recorded Module don't work

Post by binonline » Fri Apr 20, 2012 3:45 pm

Hi Markus,
I updated Ranorex from 3.2.1 -> 3.2.3 and Play Button is working again.
Thank you,
Robert

topcatalpha
Posts: 47
Joined: Tue Sep 06, 2011 7:48 am

Re: Play Button in Studio Recorded Module don't work

Post by topcatalpha » Wed Oct 17, 2012 8:35 am

Hi,

i still have this problem with versions 3.1.3 even after reinstalling the software.
How can i solve this ?

Starting the recorded test results, keeps opening logfilewindows continiously...


Urgent please !!!

Regards,

Kurt

topcatalpha
Posts: 47
Joined: Tue Sep 06, 2011 7:48 am

Re: Play Button in Studio Recorded Module don't work

Post by topcatalpha » Wed Oct 17, 2012 8:41 am

The same problem happens when i open a rxlog with ranorex report viewer.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Play Button in Studio Recorded Module don't work

Post by Support Team » Wed Oct 17, 2012 1:08 pm

Hi,

Did you reinstall it with the setup.exe file?
If not please reinstall it, as this exe will automatically install the needed packages too.
Could you post or send us one of the log files ([email protected])?

Regards,
Markus
Ranorex Support Team
.
Image

topcatalpha
Posts: 47
Joined: Tue Sep 06, 2011 7:48 am

Re: Play Button in Studio Recorded Module don't work

Post by topcatalpha » Thu Oct 18, 2012 1:55 pm

seems reinstall didn't work immediate. i had to close some files in the ranorexx project to stop the windows popups. once closed, i could open logfiles without problems.

Problem solved. Thx.

User avatar
Kenyonn
Posts: 1
Joined: Thu Aug 23, 2012 12:21 pm
Location: USA
Contact:

Re: Play Button in Studio Recorded Module don't work

Post by Kenyonn » Wed Oct 24, 2012 2:54 pm

Well i also have a same problem when i open a rxlog with ranorex report viewer.
cheapest seo services

topcatalpha
Posts: 47
Joined: Tue Sep 06, 2011 7:48 am

Re: Play Button in Studio Recorded Module don't work

Post by topcatalpha » Thu Oct 25, 2012 7:29 am

Reinstall helps. But it seems you have to close the open report files in the project
. after closing the report files it all works well again.