Play Selected Item plays the whole recording

Bug reports.
andreas.tastler
Posts: 36
Joined: Mon Sep 20, 2010 10:59 am

Play Selected Item plays the whole recording

Post by andreas.tastler » Sat Mar 19, 2011 10:13 am

Hi,

Background:
I edit a recording module withe the recording editor. Now I want to run one or several selected items by clicking Play Selected Item/s on the context menu.

Issue:
If I save the recording before running the items, everything works correct. If not, the whole recording will be executed.

Addtional Infos:
I doesn't matter where the change in the recording was made.
Ranorex Studio Version 3.0.0.11639
.NET Runtime Version 4.0.30319.1

Thank you.
Regards.
Andreas

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Play Selected Item plays the whole recording

Post by Support Team » Mon Mar 21, 2011 9:31 am

Hi,

Thank you for posting us the bug. We knew about this issue and this will be fixed with a future release of Ranorex. It only happens in Ranorex Studio because the compile logic is wrong in this situation. To overcome this issue at the moment, just save the entire project and then select the items you want to play.

Regards,
Peter
Ranorex Team
.
Image

SeanP
Posts: 60
Joined: Wed Sep 01, 2010 11:48 pm
Location: Irvine California

Re: Play Selected Item plays the whole recording

Post by SeanP » Tue Apr 03, 2012 6:49 pm

Was this ever fixed? And if so in what version? I do not see anything i the change log that reflects this bug being corrected.

andreas.tastler
Posts: 36
Joined: Mon Sep 20, 2010 10:59 am

Re: Play Selected Item plays the whole recording

Post by andreas.tastler » Wed Apr 04, 2012 5:45 am

Hi

I don't know in which release this bug has been fixed. But currently I am using Ranorex 3.2.1.15734 and it's working just fine.

Regards
Andreas

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Play Selected Item plays the whole recording

Post by Support Team » Wed Apr 04, 2012 11:59 am

Hi,
SeanP wrote:Was this ever fixed? And if so in what version? I do not see anything i the change log that reflects this bug being corrected.
Please update to the latest version. This bug should be fixed since 3.2.0.

Regards,
Peter
Ranorex Team
.
Image

SeanP
Posts: 60
Joined: Wed Sep 01, 2010 11:48 pm
Location: Irvine California

Re: Play Selected Item plays the whole recording

Post by SeanP » Wed Apr 04, 2012 10:05 pm

I am a bit apprehensive to upgrade as we are on 3.0.5 and do not want to gain any other unknowing bugs. If i can make a smaller jump that would be better. You guys dont have a bug tracking system that says what release the change went in?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Play Selected Item plays the whole recording

Post by Support Team » Thu Apr 05, 2012 4:04 pm

Hi,
SeanP wrote:I am a bit apprehensive to upgrade as we are on 3.0.5 and do not want to gain any other unknowing bugs. If i can make a smaller jump that would be better. You guys dont have a bug tracking system that says what release the change went in?
I've searched the change log of the commits and the fix should be in Ranorex 3.1.3.

Regards,
Peter
Ranorex Team
.
Image

SeanP
Posts: 60
Joined: Wed Sep 01, 2010 11:48 pm
Location: Irvine California

Re: Play Selected Item plays the whole recording

Post by SeanP » Thu Apr 05, 2012 5:13 pm

Thank you.

One issue. In your "Announcement" section I do not see a 3.1.3 version released. Is there another place i can find this version and its change log?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Play Selected Item plays the whole recording

Post by Support Team » Thu Apr 05, 2012 8:10 pm

Hi,
SeanP wrote:Is there another place i can find this version and its change log?
The download link of version 3.1.3 can be found at:
Ranorex-3.1.3
You can find the release notes using following URL:
http://www.ranorex.com/download/release-notes.html

Regards,
Tobias
Ranorex Team
.
Image

Gontee
Posts: 2
Joined: Tue Jun 05, 2012 11:23 am

Re: Play Selected Item plays the whole recording

Post by Gontee » Thu Jul 05, 2012 2:44 pm

Hello,

I have Ranorex version 3.2.316825 and I am experiencing this bug in an inconsistent way (sometimes it works and sometimes it doesn't).
Has anyone else experienced this issue since version 3.2.0?

Thank you.

Gontee
Posts: 2
Joined: Tue Jun 05, 2012 11:23 am

Re: Play Selected Item plays the whole recording

Post by Gontee » Thu Jul 05, 2012 4:50 pm

Note: it is possible that this issue recurs when choosing MANY items to play (over 30 items)

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Play Selected Item plays the whole recording

Post by Support Team » Fri Jul 06, 2012 5:28 pm

Hello,

It should make no difference.
Could you please also send us a detailed description of the executed steps which should lead to this behavior?
Do you have tried to upgrade to Ranorex 3.3, if yes did you notice the same issue with this version?
Thanks in advance!

Regards,
Markus
Ranorex Support Team
.
Image

User avatar
IanF
Posts: 60
Joined: Thu May 24, 2012 12:37 am
Location: Brisbane, Australia
Contact:

Re: Play Selected Item plays the whole recording

Post by IanF » Sun Jul 08, 2012 11:33 pm

This bug still exits in 3.3.0.17843...?
Ian Fraser

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Play Selected Item plays the whole recording

Post by Support Team » Tue Jul 10, 2012 2:15 pm

Hi,

I tested it with the actual 3.3.1 and it worked as expected.

Regards,
Markus
Ranorex Support Team
.
Image

solovengo
Posts: 24
Joined: Mon Dec 19, 2011 8:14 pm

Re: Play Selected Item plays the whole recording

Post by solovengo » Thu Jul 12, 2012 8:45 pm

I think the bug still exists. I am using 3.3.0.17843.

From time to time I see the incorrect "play all" behavior when I select specific items, sometimes even when selecting as few as 1 item. It is not consistent though. When it does starting happening, I have had to Save All, Close and reopen Ranorex, then I recompile the project and I can resume using Play Selected Item(s). I don't know if it necessary to go through all of the saving, closing, and recompiling, but it gets me back to being able to use Play Selected Item(s).