PopUp Watcher not working using Ranorex Agent

Class library usage, coding and language questions.
Mr.Papou
Posts: 6
Joined: Mon Jul 29, 2019 6:39 pm

PopUp Watcher not working using Ranorex Agent

Post by Mr.Papou » Mon Sep 30, 2019 6:40 pm

Hello,

Is there an possible explanation on why the PopUp Watcher from the Ranorex Automation Helper would not work when using by a Ranorex Agent?

When I use my Test Suite on my local machine, it works correctly. But when I try to launch the same Test Suite, using a Ranorex Agent, when the Popup shows, it simply does not see it. I have verified the RxPath with Ranorex spy and on both machine he can see the element.

What I've already tried:
- I've set a 10 second delay in my PopUp watcher recording module. Still not working.
- I've placed my PopUp watcher in the setup, instead of directly in the test suite. Still not working.

The only thing that seems to be working, is when I use a user code module that I've made, but this bring other undesired problems, see the link:
https://www.ranorex.com/forum/popup-wat ... 14554.html

I'm using Ranorex version 9.1.1

Thank you in advance,
Pascal

User avatar
Support Team
Site Admin
Site Admin
Posts: 11987
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: PopUp Watcher not working using Ranorex Agent

Post by Support Team » Tue Oct 01, 2019 3:38 pm

Hi Mr.Papou,

To better understand what Ranorex is seeing during the test run, capture a Ranorex Snapshot of your application during runtime right after this popup exists. You can do this by using a "Create snapshot" action on the AUT's root repository item. Once added, run the test until it fails. Once it fails, look at the Ranorex Snapshot in the Ranorex Report and see if your RxPath to the popup finds the popup or if the RxPath is different. If it is different, hopefully, the snapshot will give you some information on why and you can make adjustments to your RxPath accordingly.
1.png
1.png (17.46 KiB) Viewed 73 times

I hope this helps!

Cheers,
Ned
.
Image

Mr.Papou
Posts: 6
Joined: Mon Jul 29, 2019 6:39 pm

Re: PopUp Watcher not working using Ranorex Agent

Post by Mr.Papou » Tue Oct 01, 2019 4:42 pm

Thanks for the answer, I'll try that. But for the test, I'm on RDP on the PC that run the agent and when I run the test suite to see what going on and I clearly see the PopUp on the screen, he exist, he's visible and he has focus.

Mr.Papou
Posts: 6
Joined: Mon Jul 29, 2019 6:39 pm

Re: PopUp Watcher not working using Ranorex Agent

Post by Mr.Papou » Wed Oct 02, 2019 6:54 pm

In the end I was able to fix my issue by fixing my PopUpWatcher user code and I use it instead of the PopupWatcher from the Ranorex Automation Helpers.

Thanks for your help
Pascal